Bug 104627 - FILEOPEN: very slow-loading of large .docx created saving .odt with many sections and footnotes (previously created from .doc/x) - faster in MSO
Summary: FILEOPEN: very slow-loading of large .docx created saving .odt with many sect...
Status: RESOLVED DUPLICATE of bug 76260
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx, haveBacktrace, perf
Depends on:
Blocks: DOCX-Opening
  Show dependency treegraph
 
Reported: 2016-12-13 09:27 UTC by Buovjaga
Modified: 2021-02-12 17:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
slow-loading .DOCX (872.34 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-12-13 12:41 UTC, tommy27
Details
stripped version. just first 100 pages (461.96 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-12-13 12:49 UTC, tommy27
Details
stripped version. just first 50 pages (213.42 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-12-13 13:14 UTC, tommy27
Details
Callgrind output from master (6.44 MB, application/x-xz)
2018-09-22 11:46 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2016-12-13 09:27:13 UTC
1. Open attachment 71267 [details]
2. Save as .docx
3. Reload

It takes a couple of minutes (didn't time) on my very fast machine.

This is spun off from bug 59918 (it doesn't freeze anymore).

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: ede1a83e110ce7bc7d3560f415d6269ea3feb947
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 13th 2016
Comment 1 tommy27 2016-12-13 10:44:33 UTC
tested under Win7x64 using LibO 5.2.3.3
FILESAVE as .docx is quite fast (few seconds).
FILEOPEN the resulting .docx takes 10 minutes under Win7x64 SP1 using LibO 5.4.0.0.alpha0+ (x64)

Build ID: 7aa2b5a041df8e71a435cccbc79ee13799ec9138
CPU Threads: 8; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-11-24_11:40:27
Locale: it-IT (it_IT); Calc: CL

my PC has an Intel Core i7 CPU 950 @ 3.07GHz, 8.0GB RAM and SSD disk.
Comment 2 tommy27 2016-12-13 12:41:17 UTC
Created attachment 129575 [details]
slow-loading .DOCX

I'm uploading the .DOCX version of the "offending" file so you don't have to convert it from .ODT to reproduce the bug.
Comment 3 tommy27 2016-12-13 12:49:11 UTC
Created attachment 129577 [details]
stripped version. just first 100 pages

in case it may help debugging here's a stripped version of the .DOCX file.

this version includes only the first 100 pages.
loading is 3 minutes against 10 minutes of the the whole document (around 240 pages if I remember correctly).
Comment 4 tommy27 2016-12-13 13:14:09 UTC
Created attachment 129580 [details]
stripped version. just first 50 pages

another stripped version, this time just the first 50 pages.
now loading time is 20 seconds.
Comment 5 Telesto 2016-12-13 21:36:02 UTC
Tested the 50 pages document. Issue also exists in:
Versie 4.0.0.3 (Bouw-id: 7545bee9c2a0782548772a21bc84a9dcc583b89)

and in
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 6 tommy27 2017-07-22 10:19:40 UTC
no performance improvement using LibO 5.3.4.2 or a recent 6.0.0.0 alpha daily build.

the 50 pages version still loads in 20 seconds under Win7x64
Comment 7 QA Administrators 2018-07-23 02:32:34 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2018-09-22 11:46:04 UTC
Created attachment 145105 [details]
Callgrind output from master

callgrind from opening attachment 129580 [details]

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 0ffa7a733d834647dfd59b864c52a015028822b6
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: threaded
Built on September 21st 2018
Comment 9 QA Administrators 2019-09-23 02:54:02 UTC Comment hidden (obsolete)
Comment 10 Telesto 2019-12-31 23:51:07 UTC
1.30 minutes for the 100 pages document. So probably improved compared to 3 minutes of comment 3
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 42a1a1c6b91907f81e15066ffab219411f18c4db
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 11 Buovjaga 2020-01-04 20:41:10 UTC
Retested, used a stopwatch and I got 2min 33s, so the same as in 2016 with the same computer.

Arch Linux 64-bit
Version: 6.5.0.0.alpha0+
Build ID: 2dfc1dce87a0509e76d3d5875e03e3fae5d677d7
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 21 December 2019
Comment 12 NISZ LibreOffice Team 2020-11-26 08:54:40 UTC
docx with many footnotes opening slowly is bug #76260 - maybe this is just a duplicate of that, but let's keep this one open in case there is something else in this.
Comment 13 László Németh 2021-02-12 17:32:59 UTC

*** This bug has been marked as a duplicate of bug 76260 ***