Bug 104634 - When a caption is added to two images next to each other (anchored As character), the image on the left will be numbered 2 instead of 1
Summary: When a caption is added to two images next to each other (anchored As charact...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha1
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Caption
  Show dependency treegraph
 
Reported: 2016-12-13 11:44 UTC by Telesto
Modified: 2020-08-05 19:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (14.17 KB, application/vnd.oasis.opendocument.text)
2016-12-13 11:44 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-13 11:44:36 UTC
Description:
The first image will be 2, the second one '1' (Maybe a notoir bug)

Steps to Reproduce:
1.Open attached file in Writer
2.Right click on the gray image and select Add caption. Add a caption an select OK
3.Next right click on the blue image and select Add caption. Add a caption an select OK
4.Take notice of the numbering order

Actual Results:  
Image 1 is 2, image 2 is 1

Expected Results:
Image 1 should be 1, image 2 be 2


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha0+
Build ID: ba6b35fc68a01aff72b39eb7809bacb326068668
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-13_06:07:39
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-12-13 11:44:53 UTC
Created attachment 129573 [details]
Example file
Comment 2 Buovjaga 2016-12-17 20:43:56 UTC
Repro, but if I change the anchoring to "To paragraph", the order becomes correct.
Works ok in 3.6.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 06ea887f8ba34a628d7641eab210501f7bd2493d
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 16th 2016

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 3 Xisco Faulí 2016-12-18 19:08:55 UTC
I can't reproduce it in

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)
Comment 5 Xisco Faulí 2016-12-18 20:54:40 UTC
Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2015-09-10 14:46:57 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2015-09-10 15:09:26 (GMT)
commit 93ab0ff24cb71c36c9e7958046e96d7472b5af90 (patch)
tree fa4c4c1e0516ac175c5d3b0fa86eaf39802fd75d
parent d961c9273104f552a8207e63c33e33f1e265565d (diff)
Related: tdf#93676 default to as-char inside captions
This will (hopefull) improve round-tripping to doc[x] for new documents because
word can only have as-char elements inside frames so we get a like-for-like
conversion if the defaults are used.

Adding Cc: to Caolán McNamara
Comment 6 QA Administrators 2017-12-19 03:33:08 UTC Comment hidden (obsolete)
Comment 7 sdc.blanco 2019-10-30 01:56:24 UTC
Repro as described in comment 2.
The instructions in the original report give the same results.
Changing the anchoring of the shapes from "as character" to "to paragraph" gives the correct (expected) order.

Version: 6.3.3.1 (x64)
Build ID: f41f4c7f9507aeca13cb9df51f34d80e8ba30a99
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win;
Comment 8 Thomas Lendo 2020-08-05 19:24:26 UTC
I cannot reproduce this issue with

Version: 7.1.0.0.alpha0+
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-08-05_04:03:50
Calc: threaded

but with

Version: 5.4.6.2
Build ID: 4014ce260a04f1026ba855d3b8d91541c224eab8
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: de-DE (de_DE.UTF-8); Calc: group

and tested with all 4 anchoring settings.

Therefore I close this bug as WORKSFORME.

If sombebody knows the repairing patch, please feel free to add it and change from WFM to FIXED.