Bug Hunting Session
Bug 104638 - UX: Frame toolbar is missing the option to create a new frame
Summary: UX: Frame toolbar is missing the option to create a new frame
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta2
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2016-12-13 13:39 UTC by Telesto
Modified: 2017-01-02 15:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-13 13:39:48 UTC
Description:
The frame toolbar doesn't contain the option to create new Frame by default.
But why not?

Steps to Reproduce:
1. Open Writer.
2. Enable Frame menu: Menu View -> Toolbars -> Frame
3. Frame toolbar is gray out because there isn't a frame.



Actual Results:  
It isn't possible to add a (interactive) frame with the frame toolbar. Interactive because, table toolbar also contains a 'interactive' one. 

Another question is whether Menu Insert -> Frame should contain "Interactive Frame' and 'Frame'. It's inconstant with the way way tables are inserted. 
Menu Table - Insert table generates a dialog box. It can be done without. 
On the other hand, the frame is not toolbar isn't activated by default.

Expected Results:
It should be possible to add a frame with the frame toolbar


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Heiko Tietze 2016-12-19 16:42:05 UTC
Those toolbars are typically for modification of objects. The same is true for shapes where adding another shape is not available. WFM, other opinions?

About the menu item what is your suggestion?
Comment 2 Heiko Tietze 2017-01-02 15:23:16 UTC
(In reply to Heiko Tietze from comment #1)
> WFM, other opinions?

Not, so closing now.