Bug 104697 - date format for fields wrong when saving to DOCX
Summary: date format for fields wrong when saving to DOCX
Status: RESOLVED DUPLICATE of bug 99236
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-15 12:58 UTC by Thomas Weiland
Modified: 2016-12-16 21:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test document with date field. (4.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-12-15 12:58 UTC, Thomas Weiland
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Weiland 2016-12-15 12:58:12 UTC
Created attachment 129666 [details]
Test document with date field.

I use the German version of LibreOffice.
I created a new text document and added a date field with formatting "31. Dezember 1999" to the document.

On the screen is displayed: 15. Dezember 2016.

Then I save the document in the MS Office DOCX-Format and close it. After opening it again in LibreOffice it shows:
31. December 2016

This means, the language for the paragraph has been switched from German to English. I can now format the language for the paragraph to German again, but when I save and open again, I will get the english date again.

Test document attached.
Comment 1 Telesto 2016-12-16 12:44:58 UTC
Sounds like bug 99236
Comment 2 Buovjaga 2016-12-16 21:09:44 UTC
Yeah, let's dupe.

*** This bug has been marked as a duplicate of bug 99236 ***