Bug 104714 - FILEOPEN: DOCX: Extra paragraph added to first page
Summary: FILEOPEN: DOCX: Extra paragraph added to first page
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:5.4.0 target:5.3.0.1
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks:
 
Reported: 2016-12-16 12:39 UTC by Xisco Faulí
Modified: 2017-05-18 18:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (293.23 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-12-16 12:39 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-12-16 12:39:32 UTC
Created attachment 129692 [details]
sample

Steps:
1. Open attached document

Observed behaviour: Extra paragraph added to the first page displaying an extra horizontal line

Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: 634589b340316ba64b731b4d923c1056be415494
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Xisco Faulí 2016-12-16 12:40:27 UTC
Regression introduced by:

author	Justin Luth <justin_luth@sil.org>	2016-07-23 06:10:29 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-07-27 12:55:13 (GMT)
commit	91ad1017b609be6fceccd392006dd9ab60724352 (patch)
tree	95769925bb502e3fa7dfd318eb1e0cf9327bcdec
parent	0d174c974819d781804026f4c7e916a8092315c5 (diff)
tdf#75573 - docx don't remove frame anchor paragraph
frames anchor to the following paragraph.  Don't remove
an empty paragraph if it follows a frame or else the frame
will jump to the next page.

This gets a bit complicated because headers/footers contain
paragraphs that aren't really "following" the frame paragraph,
and so wouldn't be used as anchor paragraphs.
There may be similar sub-paragraphs for comments etc, but
exceptions for those can be added when proof documents are found.

Adding Cc: to Justin Luth
Comment 2 Justin L 2016-12-17 14:46:45 UTC
The original was bug 75573.  Proposed fix at https://gerrit.libreoffice.org/32121
Comment 3 Commit Notification 2016-12-17 16:20:20 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=223dd0c15e383144bdeea040f86efb7a06f89450

tdf#104714 bRemove paragraph: ignore frames in Headers/Footers

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-12-20 06:22:31 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ce758326191d66520ecba94c8a62a98dcfa3846b&h=libreoffice-5-3

tdf#104714 bRemove paragraph: ignore frames in Headers/Footers

It will be available in 5.3.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.