Bug 104738 - FILEOPEN: Rotated labels in chart are displayed horizontally
Summary: FILEOPEN: Rotated labels in chart are displayed horizontally
Status: RESOLVED DUPLICATE of bug 103765
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2016-12-17 19:17 UTC by Xisco Faulí
Modified: 2016-12-20 12:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (56.18 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-12-17 19:17 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-12-17 19:17:46 UTC
Created attachment 129729 [details]
sample

Steps:
1. Open attached document

Observed behaviour: Labels in x-axis are horizontal while they should be rotated

Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: 634589b340316ba64b731b4d923c1056be415494
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Khaled Hosny 2016-12-20 00:29:21 UTC

*** This bug has been marked as a duplicate of bug 103765 ***
Comment 2 Xisco Faulí 2016-12-20 00:39:56 UTC
Hi Khaled,
Just to be sure, is it correct to close this as a duplicate of bug 103765 ? that bug seems to be related to the menus rendering...
Comment 3 Khaled Hosny 2016-12-20 00:43:32 UTC
Yes, after 2 days of debugging it turned out the same underlying issue; the text is shorter with the new layout engine and as such the labels don’t overlap and don’t get rotated (they get rotated only when they overlap).
Comment 4 Xisco Faulí 2016-12-20 12:07:23 UTC
Verified in

Version: 5.4.0.0.alpha0+
Build ID: 5a20df55ff829978c880b22e0a1f32c35d0ba30f
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group