Bug 104762 - With Wayland, cells selection in Insert > Chart… is acting random
Summary: With Wayland, cells selection in Insert > Chart… is acting random
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Wayland Chart-Wizard
  Show dependency treegraph
 
Reported: 2016-12-18 19:58 UTC by Clément L.
Modified: 2017-10-30 13:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clément L. 2016-12-18 19:58:28 UTC
Bug reproduced with both libreoffice-still and libreoffice-fresh on two different Archlinux computers.

STR:
In Calc, try to Insert > Char… and click on one of the buttons to select cells range in "Data Series" or "Data Range" in the wizard.

You will notice that when you hold your click and select cells, the rectangle of your selection is acting pretty randomly, the limit often not stopping on the cell under your cursor.

A second part to the problem is that even when you think you selected the correct cells with what you see on your screen, when releasing your mouse button  it can happen that completed range text in the wizard window doesn't match what was selected in the sheet.

When trying the same thing on a Xorg session, this bug doesn't occur, reflecting this is only affecting Wayland.
Comment 1 Jonathan Dawes 2017-07-04 20:58:00 UTC
I am seeing the same behaviour with Wayland, but while entering formulae like =sum(<range>)

Selecting the cell range gives the random results while moving the mouse and a different final result as described.  It works 100% under Xorg.

Interestingly simply selecing cells works just fine; it seems only related to expressions etc, where the cell is colour-highlighted

The problem has been around for quite some time.
Comment 2 Jean-Baptiste Faure 2017-09-11 04:57:32 UTC
Set version. On 2016-12-18 LibreOffice Still was 5.1.6.
Comment 3 Clément L. 2017-10-30 13:35:15 UTC
It doesn't seem to reproduce anymore on 5.4.2
Therefore, closing as WFM.