Bug 104823 - For Word 2016 Content Controls Placeholder Text is Being Displayed Instead of Text from XML
Summary: For Word 2016 Content Controls Placeholder Text is Being Displayed Instead of...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All All
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:7.4.0 target:7.3.0.2
Keywords: filter:docx
: 100493 (view as bug list)
Depends on:
Blocks: DOCX-Content_Control
  Show dependency treegraph
 
Reported: 2016-12-20 20:32 UTC by Andreas Hofmann
Modified: 2022-09-06 00:39 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
.docx file with Content Control (21.83 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-12-20 20:32 UTC, Andreas Hofmann
Details
The example document in current master (206.37 KB, image/png)
2021-12-20 11:13 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Hofmann 2016-12-20 20:32:03 UTC
Created attachment 129827 [details]
.docx file with Content Control

This issue was first brought up by Timur Sattarov on Dec 1, 2015, but then deemed a duplicate of bug 50097:

When reading docx file that contains Word Content Controls, MS Word shows "data from databinding", but Libreoffice shows only the placeholder text.

Note: This is NOT a duplicate of bug 50097 as this issue is about the wrong text being displayed when a .docx file is opened in Writer. Instead of resolving the XML file and displaying the text from the XML file (like Word 2016 does), Write just displays the placeholder text.
Comment 1 Buovjaga 2016-12-31 15:15:49 UTC
Confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: fc0d4e6bc43d5f982452df07930f5ecf5927ad22
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 31st 2016
Comment 2 QA Administrators 2018-01-12 03:30:47 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2020-01-13 03:35:13 UTC Comment hidden (obsolete)
Comment 4 NISZ LibreOffice Team 2020-03-30 17:46:44 UTC
This is the Rich Text type content control, modifying meta bug.

Still only the placeholder text is imported in:

Version: 7.0.0.0.alpha0+ (x64)
Build ID: bc898e2c2784e36ad4d4cdf6d962e39069d2c82d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL
Comment 5 Commit Notification 2021-12-18 14:55:32 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/be172e5a93a94b2c615dc0aae0979b9a9fa9ebab

tdf#104823: basic support for reading field data from databinding

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2021-12-19 23:16:52 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b5c616d10bff3213840d4893d13b4493de71fa56

tdf#104823: support for sdt plain text fields

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Gabor Kelemen (allotropia) 2021-12-20 11:13:03 UTC
Created attachment 177030 [details]
The example document in current master

Works in: 

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 82ceab070de76d447505a598d07d5a9a1c48d80d
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: hu-HU (hu_HU.UTF-8); UI: hu-HU
Calc: threaded

Also this survives a save-reload in docx format.
Comment 8 Gabor Kelemen (allotropia) 2021-12-20 11:26:11 UTC
*** Bug 100493 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2021-12-21 22:24:11 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/c3d3eb7bdcb07824af7d205112f36201634aee59

tdf#104823: basic support for reading field data from databinding

It will be available in 7.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-12-21 22:25:26 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/a4432eb0946c0bc775b3d30b634bef5d66544f8d

tdf#104823: support for sdt plain text fields

It will be available in 7.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2021-12-22 16:42:50 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c38dbafe0f332c6c263d1412eb41572222120c5c

tdf#104823: unittest

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-12-23 14:54:39 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/aa386d346a646db34975089282f37264ae32a2de

tdf#104823: unittest

It will be available in 7.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.