Bug 104847 - FILEOPEN DOC: Cross-page table to short, changing the page layout
Summary: FILEOPEN DOC: Cross-page table to short, changing the page layout
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-21 19:11 UTC by Telesto
Modified: 2020-05-04 12:58 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-21 19:11:27 UTC
Description:
The table ending on page 2 is wrong (to short), changing the layout of page 3.


Steps to Reproduce:
1. Open attachment 63766 [details] (bug 51691 (recently fixed))
2. Scroll to page 2
3. Compare with page 2 in Word (attachment 63767 [details])



Actual Results:  
Table doesn't reach till end of page 2

Expected Results:
Table should reach till the end of the page 2


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.0.alpha0+
Build ID: 9cfb2f2f03b5ec086487fd483298466db0b09010
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-20_23:58:02
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Mike Kaganski 2016-12-21 20:29:52 UTC
This is caused by commit 6f5024de2e1a5cc533527e45b33d9a415467c48d.

And it is not a bug, it works as intended.
The minimal row height ensures that if the row content is shorter than the minimal value, then minimal value is used. In LO, when that minimal height couldn't fit to page, then the row didn't split to next page. But now we have fixed that, and when we flow to next page, we add the height to what was left on first page.

E.g., in this file, the minimal row height is 27.56 cm, and page body height is only 29.7 cm - 2*2 cm = 25.7 cm. If there were no text in the row, then the first 25.7 cm should be on first page, and the rest of 1.86 cm should go to second. But there is much data in the row, it takes total of 48.05 cm, which puts 22.35 cm to the second page. That second page has yet another 3.35 cm free space left, which is taken by the text.

That MS Word repeats the minimal height on each page is its own bug. Saying that, I must add that we cannot mimic its bug, because if we try to put the minimal height on each page, it will revert us to the previous state, where we won't be able to see the table below the first page.

The proper way of fixing this is unfortunately to fix the document itself, by setting the text after the table to start on the next page.
Comment 2 Justin L 2020-05-04 12:58:14 UTC
I have to agree with Mike that this is a WONTFIX. The row has a minsize of 27.5cm - about the size of one page.  Well, it covers two pages, so it ought to have satisfied the minsize of one page. That is a pretty weird decision on MS' part to apply the minimum to every page.  (Probably it is an implementation error on their part that they have to live with.)