Bug Hunting Session
Bug 104929 - Give a single notice notice for bad JRE version and not many times at launch
Summary: Give a single notice notice for bad JRE version and not many times at launch
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All Windows (All)
: lowest enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Java-Runtime-JRE-Warnings Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2016-12-26 13:35 UTC by Volga
Modified: 2018-08-08 22:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2016-12-26 13:35:56 UTC
Description:
I found if Java RE I have installed is not compatible with LibreOffice, then LibreOffice give me a notice so many time until it was launched.

Steps to Reproduce:
I have previously installed LibreOffice 5.2.3 x86-64 version, and choosen 64bit version of JRE in Options. Later I download & install LibreOffice 5.2.4 x86 version. Then I open it.

Actual Results:  
When I launch LibO, it give me so many notice as this:

LibreOffice 需要 Java 运行时环境 (JRE) 才能执行此项操作。选定的 JRE 有缺陷,请选择另外一个 JRE 版本,或者安装一个新的 JRE 并在 ”工具 - 选项 - LibreOffice - 高级“那里选择它。
https://ooo.0o0.ooo/2016/12/26/5861187007280.png

LibreOffice need Java Runtime Environment (JRE) to execute this operation. The selected JRE having a defect, please select another version of JRE, or installing a new version of JRE and selecting it at “Tools - Options - LibreOffice - Advanced”.

This problem affect all versions of LibreOffice I have installed.

Expected Results:
If LibreOffice found JRE is not compatible once, then notice it once and ignore it. Also need to judge JRE is either x86 or x64 version to avoid unexpected results.


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.2.4.2
Build ID: 3d5603e1122f0f102b62521720ab13a38a4e0eb0
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
Locale: zh-CN (zh_CN); Calc: group



User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Joel Madero 2016-12-26 16:45:53 UTC
Works as designed but seems like a fine valid enhancement request.

Note: Enhancement requests are almost entirely handled by volunteers, there is no guarantee the request will ever be implemented. A volunteer would have to have the time, skill, and desire to fix it.
Comment 2 QA Administrators 2018-01-27 03:26:45 UTC Comment hidden (obsolete)
Comment 4 Volga 2018-01-28 17:26:05 UTC
Still reproduce with:

Version: 6.0.0.3
Build ID:64a0f66915f38c6217de274f0aa8e15618924765
CPU 线程:4; 操作系统:Windows 10.0; UI 渲染:默认; 
区域语言:zh-CN (zh_CN); Calc: group

And JRE Version 8 Update 161, 64 bit
Comment 5 Volga 2018-01-28 17:28:51 UTC
The problem seems appearing while LibreOffice load an extension.
Comment 6 Volga 2018-01-28 17:47:44 UTC
And I installed so many extensions as this site recommeneded:
https://www.libreofficechina.org/forum-47-1.html
Comment 7 Mike Kaganski 2018-07-31 18:02:01 UTC
The commit mentioned in comment 3 is for 6.1; so please check this version.
Comment 8 Volga 2018-08-08 18:26:06 UTC
Yeah, I got LibO 6.1 and the notice works fine to me.