Bug 104938 - About LibreOffice is reporting a wrong windows version
Summary: About LibreOffice is reporting a wrong windows version
Status: RESOLVED DUPLICATE of bug 100233
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta1
Hardware: All Windows (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-27 10:35 UTC by Telesto
Modified: 2016-12-27 17:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-27 10:35:49 UTC
Description:
The about screen is reporting "Windows 6.19", but it should be "Windows 6.2"

Steps to Reproduce:
1.Use Windows 8
2.Open LibreOffice
3.Go to help -> about

Actual Results:  
About screen is reporting Windows 6.19

Expected Results:
Should be Windows 6.2


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in:
Version: 5.4.0.0.alpha0+
Build ID: d0288a482a3dc0f50f535565e4c66a95bb140942
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-26_23:25:18
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 5.3.0.0.beta1  (x64)
Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU Threads: 4; Versie besturingssysteem:Windows 6.19; UI Render: standaard; Layout Engine: new; 
Locale: nl-NL (nl_NL); Calc: CL

but not in
Versie: 5.3.0.0.alpha1 
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 V Stuart Foote 2016-12-27 17:04:32 UTC
Confirming, but  interesting on Windows 10 Pro 64-bit I get a "6.19" ident with 
Version: 5.3.0.0.alpha1 (x64)
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US); Calc: CL

@Michael S. -- something more than https://cgit.freedesktop.org/libreoffice/core/commit/?id=4500afcc1be7774b3c35ab69a20e36165ca5445a needed for WinSalInstance [1] at this point for 8, 8.1 and 10 builds of Windows?

In https://msdn.microsoft.com/en-us/library/ms724834(VS.85).aspx there is the note:

For applications that have been manifested for Windows 8.1 or Windows 10. Applications not manifested for Windows 8.1 or Windows 10 will return the Windows 8 OS version value (6.2). To manifest your applications for Windows 8.1 or Windows 10, refer to Targeting your application for Windows.

Guess since we do not manifest for Windows 8.1 or 10 we get 6.2--incorrectly being displayed as 6.19

Markus and Tomaž have been able to get good OS version resolution for the driver details [2]


=-ref-=
[1] http://opengrok.libreoffice.org/xref/core/vcl/win/app/salinst.cxx#431

[2] http://opengrok.libreoffice.org/xref/core/vcl/opengl/win/WinDeviceInfo.cxx#146
Comment 2 V Stuart Foote 2016-12-27 17:16:13 UTC

*** This bug has been marked as a duplicate of bug 100233 ***