Bug 104939 - OPENGL: Font preview in the character dialog is mangled with OpenGL enabled
Summary: OPENGL: Font preview in the character dialog is mangled with OpenGL enabled
Status: RESOLVED DUPLICATE of bug 103831
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: VCL-OpenGL HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2016-12-27 10:54 UTC by Telesto
Modified: 2017-01-29 14:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (19.18 KB, image/png)
2016-12-27 10:55 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-27 10:54:49 UTC
Description:
Font preview in the character preview is mangled with OpenGL enabled

Steps to Reproduce:
1.Open Impress (and select a template)
2.Check if OPENGL is enabled
2.Right click on the bottom textbox
3.Select character

Actual Results:  
Font preview is mangled

Expected Results:
Should be mangled


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.0.alpha0+
Build ID: d0288a482a3dc0f50f535565e4c66a95bb140942
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-26_23:25:18
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-12-27 10:55:30 UTC
Created attachment 129958 [details]
Screenshot
Comment 2 Telesto 2016-12-27 10:58:30 UTC
OpenGL.log
DriverVersion: 13.251.0.0
DriverDate: 12-6-2013
DeviceID: PCI\VEN_1002&DEV_683D&SUBSYS_25561458&REV_00
AdapterVendorID: 0x1002
AdapterDeviceID: 0x683d
AdapterSubsysID: 0x25561458
DeviceKey: System\CurrentControlSet\Control\Video\{B91C0DAC-2248-498B-81BF-9885063205E2}\0000
DeviceString: AMD Radeon HD 7700 Series
Comment 3 V Stuart Foote 2016-12-27 17:33:30 UTC
Confirmed on Windows 10 Pro 64-bit en-US with
Version: 5.4.0.0.alpha0+
Build ID: 0ba8da916429ca768989cb1046df9b28ff52ec37
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-26_00:57:45
Locale: en-US (en_US); Calc: CL

With OpenGL rendering enabled the glyph spacing is wrong for the sample/or selected text in the Character dialog.

Text is correctly rendered to presentation canvas--just the dialog's preview is affected.

With default rendering, the layout is correct in the dialog and on canvas.
Comment 4 V Stuart Foote 2017-01-29 14:29:43 UTC
with bug 103831 reopened this is duplicate

*** This bug has been marked as a duplicate of bug 103831 ***