Bug 104941 - Items in the navigator deck flicker with certain documents
Summary: Items in the navigator deck flicker with certain documents
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.6.3 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Flickering-UI
  Show dependency treegraph
 
Reported: 2016-12-27 13:34 UTC by Telesto
Modified: 2019-05-04 14:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (18.79 KB, application/vnd.oasis.opendocument.text)
2016-12-27 13:35 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-27 13:34:48 UTC
Description:
The items in the navigator deck flicker a bit with certain documents

Steps to Reproduce:
1.Open attached document
2.Enable the sidebar/navigator deck
3.Click in the gray area around the paper 
4.Don't move the mouse; flickering should start occur within 15 seconds

Alternative route; click the pdf-export button and wait short period

Actual Results:  
The items in the navigator deck are flickering a bit

Expected Results:
Steady deck


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in:
Version: 5.4.0.0.alpha0+
Build ID: d0288a482a3dc0f50f535565e4c66a95bb140942
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-26_23:25:18
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-12-27 13:35:09 UTC
Created attachment 129960 [details]
Example file
Comment 2 V Stuart Foote 2016-12-27 17:44:15 UTC
Confirmed, the "flicker" matches the rate of the text cursor blink--with and without GPU hardware enabled.

But flicker of the navigator Sidebar deck does not occur with OpenGL enabled.

On Windows 10 Pro 64-bit en-US with
Version: 5.4.0.0.alpha0+
Build ID: 0ba8da916429ca768989cb1046df9b28ff52ec37
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-26_00:57:45
Locale: en-US (en_US); Calc: CL
Comment 3 Buovjaga 2018-04-30 18:25:41 UTC
Not reproduced. Is it fixed for you as well?

Version: 6.1.0.0.alpha1 (x64)
Build ID: cb47f0d320994e001bc38dc2ee9b7d957b15e6ab
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: fi-FI (fi_FI); Calc: group

Arch Linux 64-bit
Version: 6.1.0.0.alpha1+
Build ID: 632bc11ce8fab1c4046ab24810b90a7ce9ac5914
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 27th 2018
Comment 4 Telesto 2018-05-01 16:10:34 UTC
Still repro for in the Navigator deck
Version: 6.1.0.0.alpha0+
Build ID: 2ed7c02478968852d7d39c2c4677f2ecf3441bc7
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-04-22_01:00:56
Locale: nl-NL (nl_NL); Calc: CL
Comment 5 QA Administrators 2019-05-02 02:48:05 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2019-05-04 12:25:04 UTC
don't repro in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 7ca7d61dc25f409e209b3a432c7f07469b17e316
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-03_23:08:41
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL

I have AMD HD7660D video in APU AMD A10-5700 here

Telesto, please retest it yourself
Comment 7 Telesto 2019-05-04 14:06:27 UTC
(In reply to Roman Kuznetsov from comment #6)
Thanks for testing :-)

No repro either:

Version: 6.3.0.0.alpha0+
Build ID: 3083fe569f96bf0289da1e9d0ef7da15ab22e2f6
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-04-16_01:39:55
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded

->WFM