Bug 104950 - Dates in MY (Malaysia) English localization: incorrect.
Summary: Dates in MY (Malaysia) English localization: incorrect.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Eike Rathke
URL:
Whiteboard: target:5.4.0 target:5.3.0.2 target:5.2.6
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-28 06:41 UTC by yinlkwong
Modified: 2017-01-18 09:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
format cell window showing default en- MY IN LANGUAGE BOX (57.86 KB, image/jpeg)
2017-01-16 06:14 UTC, yinlkwong
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yinlkwong 2016-12-28 06:41:14 UTC
Description:
The format for Malaysia for date is DDMMYY. 
Those who use the computer may notknow how to set correct localization. They use default US localization which is in the form MMDDYY  
I tried to change the localization to UK which is DDMMYY but is not reflected in the individual cells.

Steps to Reproduce:
1.Click the column headers Drag mouse and select the columns.
2.Click format cell
3. Language change to UK English.
4. Save and close the file.
5. Open the file.
6. Click any date cell in the column.
7. Format cell.  Look at Language. It show the old one MY English.

Actual Results:  
Not applicable

Expected Results:
Not applicable


Reproducible: Always

User Profile Reset: No

Additional Info:
I am the only user.
Workaround  I use text instead of date format


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Buovjaga 2017-01-03 16:36:07 UTC
Why do you use UK and not Malay? I used Malay for testing and I did not see your problem.
The format for UK and Malay is DD/MM/YY (in LibreOffice).

Also, why do you mention Malaysian English, when there is no such available?

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: fc0d4e6bc43d5f982452df07930f5ecf5927ad22
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 31st 2016

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.4.2.0+
Build ID: 5.2.4-1
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 2 yinlkwong 2017-01-16 06:09:31 UTC
Calc version 5.1.4.2 under ubuntu 16.04 do not have default - en My localisation.

This default - en My localisation is found in calc running under win 10. Suspect it is derived from the win 10 input language  english - Malaysia.

I think the solution is to create english malaysia localisation which is similar to malay localisation (DDMMYY) except that the language is english. 
Note: Most of the private business community use english -My. 

Only in government sector some use Malay localisation.
Comment 3 yinlkwong 2017-01-16 06:14:35 UTC
Created attachment 130466 [details]
format cell window showing default en- MY  IN LANGUAGE BOX
Comment 4 Buovjaga 2017-01-16 09:56:16 UTC
Eike: thoughts?
Comment 5 Eike Rathke 2017-01-16 12:13:44 UTC
From what I understood this is actually an enhancement request to add English (Malaysia) [en-MY] locale data, derived from en-GB but with MYR/RM currency of course. Correct?
Comment 6 yinlkwong 2017-01-16 13:26:18 UTC
Can consider this as an enhancement request. 
Hope to see it resolve soonest possible.
If it is too long to add,the win 10 version 5.2.3.3 should not add default en-My. It should use english uk localisation. This is because the uk date format is consistent to DDMMYY.
Comment 7 yinlkwong 2017-01-16 13:31:34 UTC
At least the historical dates in the calc file are consistent. The monetary values need not add rm or uk, just plain decimal numbers or numbers with custom format.
Comment 8 Eike Rathke 2017-01-16 14:42:00 UTC
(In reply to yinlkwong from comment #6)
> If it is too long to add,the win 10 version 5.2.3.3 should not add default
> en-My. It should use english uk localisation.
There won't be a new locale for 5.2.z, as a new locale would also introduce a new UI string in the language listbox, which we don't add for micro releases because of the required subsequent translations. However, maybe a fallback to en-GB instead of en-US could be implemented, I'd have to investigate.
Comment 9 Eike Rathke 2017-01-16 14:48:59 UTC
(In reply to yinlkwong from comment #0)
> Steps to Reproduce:
> 1.Click the column headers Drag mouse and select the columns.
> 2.Click format cell
> 3. Language change to UK English.
> 4. Save and close the file.
> 5. Open the file.
> 6. Click any date cell in the column.
> 7. Format cell.  Look at Language. It show the old one MY English.
I could not reproduce that btw. Once an explicit "English (UK)" date number format is applied it stays. Note that this is *not* Font Language but Numbers Language.
Comment 10 Eike Rathke 2017-01-16 20:10:10 UTC
(In reply to Eike Rathke from comment #8)
> There won't be a new locale for 5.2.z, as a new locale would also introduce
> a new UI string in the language listbox
Actually that may be a little exceptional here, as en-MY is already defined as a known locale but just has no UI string yet. So adding just the locale data might work.
Comment 11 Commit Notification 2017-01-16 20:29:05 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4cc33214a5acf278b9549e21627ff44a01ce5f5f

tdf#104950 add English (Malaysia) [en-MY] locale data

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2017-01-16 20:29:10 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=35ed50dcd1c38bb0ec304dfc50758b96db65a8a5

Resolves: tdf#104950 add English (Malaysia) [en-MY] to language listbox

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Eike Rathke 2017-01-16 20:56:17 UTC
Pending review https://gerrit.libreoffice.org/33187 for 5-2
Comment 14 Commit Notification 2017-01-17 00:04:13 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=285194c1cceb07868eca9415b67a9b1aaae1ba56&h=libreoffice-5-3

tdf#104950 add English (Malaysia) [en-MY] locale data

It will be available in 5.3.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2017-01-17 00:12:34 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ffac20183b7986580db92ba585a80a74a8b1ef71&h=libreoffice-5-3

Resolves: tdf#104950 add English (Malaysia) [en-MY] to language listbox

It will be available in 5.3.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2017-01-18 09:11:06 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b7d08e32204fd9ec2231aaf89d18712edc1062d&h=libreoffice-5-2

tdf#104950 add English (Malaysia) [en-MY] locale data

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.