Bug Hunting Session
Bug 105025 - table corners look ugly when you increase cells border size
Summary: table corners look ugly when you increase cells border size
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Table-Borders
  Show dependency treegraph
 
Reported: 2017-01-01 11:24 UTC by jlbraga
Modified: 2019-02-02 19:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example of what I mean (62.44 KB, image/png)
2017-01-03 19:16 UTC, jlbraga
Details
Table borders in 6.3 (98.58 KB, image/png)
2019-02-02 19:07 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jlbraga 2017-01-01 11:24:20 UTC
Hi.

Create some cells. Now select them and make visible only the outlines. Now increase the thickness of the outlines to the max. What you will see is that the corners don't get perfect. In fact, they disappear!
Comment 1 Terrence Enger 2017-01-02 02:54:30 UTC
Working in debian-stretch with daily Linux dbgutil bibisect repository
version 2017-01-01, in a new worksheet, I observe ...

    In Calc, I selected cells B2:C3 and applied a 5-point border
    around the group.

    The program displays the visible border centered over the implicit
    border around the group, i.e., half inside B2:C3 and half in the
    horizontally and vertically surrounding cells, i.e., B1:C1, D2:D3,
    B4:C4, A2:A3.

    The program does not display the part of the visible border which
    would fall in the cornerwise adjacent cells, i.e. A1, D1, D4, A4.

    However, in .pdf export, ...

      - if the surrounding cells have no border specified, then the
        border around B2:C3 is complete, even showing "mitred"
        corners.

      - if the surrounding cells have border specified, then the
        border around B2:C3 is rendered as on the screen.


I agree that the handling of cornerwise adjacent cells is strange,
especially as pdf output differs from the screen rendering.  However,
I am leaving status UNCONFIRMED, as I am not sure what the correct
behaviour would be.
Comment 2 Terrence Enger 2017-01-02 02:59:10 UTC
jlbraga,

Do you see what I described?  Were you working in Calc?

Meanwhile, I am setting component Calc and O/S All.
Comment 3 jlbraga 2017-01-02 20:24:00 UTC
Oh, sorry for the delay.

No, I was not working on Calc, it was a table on Write, and my system is Windows 10.
Comment 4 tommy27 2017-01-03 13:25:27 UTC
please tell the LibO version you are using and provide a screenshot.

status NEEDINFO
Comment 5 jlbraga 2017-01-03 19:16:50 UTC
Created attachment 130122 [details]
example of what I mean

The corners should be improved...
Comment 6 tommy27 2017-01-03 21:13:31 UTC
ok, which LibO version do you use?
Comment 7 jlbraga 2017-01-03 21:19:28 UTC
5.4.2.2, I thought I had selected that option in the page top, but it was not even marked. Now it is.
Comment 8 tommy27 2017-01-03 21:47:50 UTC
I confirm issue under Win8.1 x64 using LibO 5.2.4.2 and 5.4.0.0 alpha

probably this bug has already been reported before since I'm somewhat reminiscent of something similar.

we should seek on bugzilla for a potential duplicate
Comment 9 QA Administrators 2018-01-04 03:35:56 UTC Comment hidden (obsolete)
Comment 10 Roman Kuznetsov 2019-02-02 19:06:16 UTC
table borders looks good in

Версия: 6.3.0.0.alpha0+
ID сборки: 51af3179cf972809d6495c7d58033e069f647bbf
Потоков ЦП: 4; ОС:Linux 4.18; Отрисовка ИП: по умолчанию; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-01_00:15:00
Локаль: ru-RU (ru_RU.UTF-8); UI-Language: ru-RU
Calc: threaded

Status->WFM
Comment 11 Roman Kuznetsov 2019-02-02 19:07:07 UTC
Created attachment 148859 [details]
Table borders in 6.3