Bug 105033 - impossible to set transparent background to a set of table cells painted with different color backgrounds
Summary: impossible to set transparent background to a set of table cells painted with...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest
: 105135 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-01-01 18:29 UTC by Gabriele Bertolucci
Modified: 2019-05-15 09:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
table before changing background (21.72 KB, image/png)
2017-01-02 08:37 UTC, steevie
Details
table after changing background (122.79 KB, image/png)
2017-01-02 08:38 UTC, steevie
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele Bertolucci 2017-01-01 18:29:28 UTC
Description:
I opened an ODT file which contains a table. Many cells have a colored background (the colors are multiple), others have transparent background. 1) If I select simultaneously two different colored cells (or a colored one and transparent one) and I try to set them to a transparent background, this command is not successful: nothing happens, no error messages. 2) If I select simultaneously two cells with the same color and I try to set them to a transparent background, it works correctly. 3) If I select simultaneously two different colored cells or two same colored cells and I try to set them to the same background color (no matter if it's one of the colors of the two selected cells or a third color), it works correctly.

Steps to Reproduce:
The steps are detailed in the bug description.

Actual Results:  
The result is detailed in the bug description (point 1).

Expected Results:
For point 1, I expected the cells where all set to a transparent background.


Reproducible: Always

User Profile Reset: No

Additional Info:
I tried LibreOffice in Windows 10 Pro, version 1607 (build 14393.576).


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 steevie 2017-01-02 08:37:43 UTC
Created attachment 130084 [details]
table before changing background
Comment 2 steevie 2017-01-02 08:38:28 UTC
Created attachment 130085 [details]
table after changing background
Comment 3 steevie 2017-01-02 08:38:58 UTC
I can confirm this behaviour on Linux Devuan 4.3.0-1-amd64 with Libreoffice Version: 5.2.3.3, Build ID: 1:5.2.3-2.

Setting a transparent background on cells with different background does not work even when selecting the cells, then going to Table > Properties and selecting "no fill" on Cell. 

Moreover, another odd behaviour is in the case a row contains cells with (two) diffferent background color. See screenshots. 
1. Let the first cell be of one color and all the other of different color.
2. Select the _first_ cell
3. Select a different background color for the whole row

Result: all the first row but the first cell change color.
Comment 4 simone_girardelli 2017-01-02 17:30:29 UTC
i have,

Versione: 5.3.0.0.beta1
Build ID: 1:5.3.0~beta1-1
Thread CPU: 4; Versione SO: Linux 4.8;

I confirm how other users, cells with different colors, you are not able to change color by selecting two or more cells, while with color equal, the problem does not exist.
Comment 5 Gabriele Ponzo 2017-01-05 00:11:02 UTC
I can confirm this behavior with:
Versione: 5.2.3.3
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
Thread CPU: 4; Versione SO: Mac OS X 10.8.5; Resa interfaccia: GL; 
Versione locale: it-IT (it.UTF-8); Calc: group
Comment 6 Buovjaga 2017-01-05 08:48:43 UTC
I confirm the problem with 5.2.4, but it is gone in master. Let's close as WFM and add backportrequest.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.4.2.0+
Build ID: 5.2.4-1
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 1a58cdf8af1aba52ce0a376666dd7d742234d7cf
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on January 4th 2016
Comment 7 Gabriele Bertolucci 2017-01-07 14:44:37 UTC
*** Bug 105135 has been marked as a duplicate of this bug. ***