Bug Hunting Session
Bug 105038 - Conditional formatting: more control
Summary: Conditional formatting: more control
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2017-01-02 06:38 UTC by librelibre
Modified: 2017-03-21 16:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description librelibre 2017-01-02 06:38:02 UTC
Description:
for continuous value affect formatting:
support for cell values affecting the sRGB or linearSRGB-709/XYZ..
and affecting possibility also font weight, opacity, 

for more discrete, font-family, pattern, 

via not only based of that cell's values but also relative/absolute mixed references, 
!!same even for graphs, the option for individual data points' various formatting settings and lines also (maybe since #=n-1 maybe, index of line based on previous point) 

so can use formulas to directly control but fine and coarse basis, and ability to change precendence, e.g. series formatting, indivdual data points, axis, graph; cell, row, column, whole area, and maybe if row and column intersect make the combo also possibly a combination of both previous settings
(node-based UI and coding?)

Actual Results:  
only color ramp supported or discrete formatting based on boolean conditions , >,<,=,not's  chart point's formatting have no ability yet to base on cell/relative-offset's contents

Expected Results:
more versatile as listed above


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Heiko Tietze 2017-01-05 08:56:02 UTC
I don't get what you mean, sorry. Conditional formatting means to apply a style to a cell for a defined condition. That's a WORKSFORME, despite the issue that background (color) uses the pre 5.3 approach and does not allow to set every area properties as known from shapes, for instance.

Do you suggest to enhance the cell style? That is a WONTFIX as we are bound to ODF. Or to fix an issue? And if you are talking about more elaborated conditions please specify what you expect (there are plenty right now).
Comment 2 Heiko Tietze 2017-03-21 16:47:32 UTC
Cell style works for me and there are not enough input to comment on this ticket.