Bug Hunting Session
Bug 105068 - LibreOffice sometimes become busy and unresponsive in MacOS X upon window resizing/moving
Summary: LibreOffice sometimes become busy and unresponsive in MacOS X upon window res...
Status: RESOLVED DUPLICATE of bug 103571
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-03 16:03 UTC by Wirawan Purwanto
Modified: 2017-01-03 18:09 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wirawan Purwanto 2017-01-03 16:03:06 UTC
Description:
I have LibreOffice version 5.2 (see below for exact system specs) on a Macbook Air laptop (OS: OS X El Capitan 10.11.6). Generally I am happy with this software, but from time to time it would lock up, busy, unresponsive for a reason I don't understand. I couldn't pinpoint certain action that always triggers this behavior, but I narrowed it down to resizing a document window, or moving a document window. Then the CPU usage of soffice becomes 100% for about 1 minute. I mainly observed this in Writer, but Calc also suffered the same. The "top" command shows nearly 100% CPU utilization when this happens. Usually it will resolve, but it can take minutes before it leaves the unresponsive phase. Has anyone experienced this with the MacOS X version described below? The hardware has 8GB RAM and 5th generation (Broadwell) Intel i5 CPU, so it should be adequate for this job, even with web browser and a few other applications open.

My typical usage pattern is: I open 5-10 documents at the same time, mostly writer docs saved in ODT format. These are smallish documents (<100 kB each).

Info from "about LibreOffice" box:

Version: 5.2.3.3 Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf CPU Threads: 4; OS Version: Mac OS X 10.11.6; UI Render: default; Locale: en-US (en.UTF-8); Calc: group

I have also tested LibreOffice Dev 5.3 beta 2, and it suffered with the same problem.

Steps to Reproduce:
1. Try moving a document window around
2. Or try resizing/maximizing/unmaximizing the document window

Actual Results:  
The application will hang (unresponsive) for 1 minute or more. CPU use of the application becomes 100%.

Expected Results:
Application should not hang like that!


Reproducible: Sometimes

User Profile Reset: No. But trying 5.3 beta 2 with new user profile did not help either.

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Wirawan Purwanto 2017-01-03 16:04:02 UTC
I started this as a thread in Ask LibreOffice forum, see here:

https://ask.libreoffice.org/en/question/83375/libreoffice-sometimes-become-busy-and-unresponsive-in-macos-x/

Since I did not receive a useful response and this is more a bug than a user problem, I reposted here.
Comment 2 Alex Thurgood 2017-01-03 18:08:22 UTC
@Wirawan : it is the multiple opened documents that cause this, the reason for which is as yet unknown - a bug report has already been filed for this, so your report would be a duplicate of that earlier one.
Comment 3 Alex Thurgood 2017-01-03 18:09:49 UTC

*** This bug has been marked as a duplicate of bug 103571 ***