Bug 105084 - 64-Bit Windows LibreOffice Applications hang on startup (Intel OpenCL SDK)
Summary: 64-Bit Windows LibreOffice Applications hang on startup (Intel OpenCL SDK)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: OpenCL
  Show dependency treegraph
 
Reported: 2017-01-03 23:23 UTC by Mike Allen
Modified: 2018-12-10 18:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
opencl_devices.log file (2.30 KB, text/plain)
2017-01-05 18:54 UTC, Mike Allen
Details
opencl_profile.xml (533 bytes, text/xml)
2017-01-05 18:56 UTC, Mike Allen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Allen 2017-01-03 23:23:58 UTC
Description:
I have personally tried the following 64-bit Windows LibreOffice versions, all of which hang during application start-up:
5.2.1.2
5.2.2.2
5.2.4.2

Other users (see thread links below) have reported the same problem with these 64-bit versions:
5.1.5.2
5.2.0.4
5.2.3.3

Note: I have reset my profile and disabled OpenGL without any luck. 32-bit Windows versions appear to be unaffected and just work.

My machine is a Dell Latitude E6520 with a 4-core (8 hyper-thread) Intel Core i7-2760QM processor, 8GB RAM running Windows 10 Professional 64-bit (version 1511 - NOT the Windows 10 "Anniversary Edition"). In case it's relevant, this machine has both Intel HD Graphics 3000 integrated graphics and an NVidia NVS4200M graphics card. I've tried running LibreOffice with both cards and both result in the application hanging.

Refer to these threads for more information:

https://ask.libreoffice.org/en/question/77635/libreoffice-hangs-on-startup/ (a thread I started).
https://ask.libreoffice.org/en/question/76494/64-bit-libreoffice-515-520-freezehang-while-opening-files/ (a thread started by someone else with the same problem).

(I have a Microsoft Surface Pro 3 that is successfully running 64-bit LibreOffice 5.2.2.2, so this is clearly not a problem affecting every PC.)

Let me know if there is any further information that you require.

Steps to Reproduce:
1.Run any LibreOffice application, either standalone or by clicking on a LibreOffice document.

Actual Results:  
LibreOffice logo appears, application hangs. The soffice.exe program then goes into an infinite loop, consuming all available CPU on a single thread.

Expected Results:
Application should start up normally.


Reproducible: Always

User Profile Reset: Yes.

Additional Info:
Also tried clean reinstall and also tried disabling OpenGL - no use.

32-bit releases (the 6.2.4.2 release, at any rate) are unaffected by this problem.


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36
Comment 1 Buovjaga 2017-01-05 09:28:11 UTC
From your working 32-bit LibreOffice, please copy & paste the full Help - About contents to a comment.
Comment 2 Buovjaga 2017-01-05 09:30:51 UTC
(In reply to Mike Allen from comment #0)
> https://ask.libreoffice.org/en/question/76494/64-bit-libreoffice-515-520-
> freezehang-while-opening-files/ (a thread started by someone else with the
> same problem).

Did you check, if you have this installed: Intel OpenCL SDK? LibreOffice Calc is able to use OpenCL, so I guess removing that SDK worked for those people in the thread because some conflict was removed.
Comment 3 Mike Allen 2017-01-05 17:51:59 UTC
As requested, text from the Writer Help/About LibreOffice dialog:

Version: 5.2.4.2
Build ID: 3d5603e1122f0f102b62521720ab13a38a4e0eb0
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (en_US); Calc: group

LibreOffice is a modern, easy-to-use, open source
productivity suite for word processing, spreadsheets,
presentations and more.

This release was supplied by The Document Foundation.
Copyright © 2000-2016 LibreOffice contributors.
LibreOffice was based on OpenOffice.org.
Comment 4 Mike Allen 2017-01-05 17:59:15 UTC
I do have "Intel SDK for OpenCL - CPU Only Runtime Package", version 2.0.0.37149 installed.

For the record, the problem affects all of the LibreOffice applications, not just Calc. I would prefer not to uninstall this software, because I do not have an installer for it available, so I cannot reinstall it should it prove to be required.
Comment 5 Mike Allen 2017-01-05 18:09:40 UTC
It might also worth mentioning that the Intel OpenCL SDK is NOT installed on my Microsoft Surface Pro 3, which runs the 64-bit version of LibreOffice OK.
Comment 6 Buovjaga 2017-01-05 18:19:58 UTC
(In reply to Mike Allen from comment #4)
> I do have "Intel SDK for OpenCL - CPU Only Runtime Package", version
> 2.0.0.37149 installed.
> 
> For the record, the problem affects all of the LibreOffice applications, not
> just Calc. I would prefer not to uninstall this software, because I do not
> have an installer for it available, so I cannot reinstall it should it prove
> to be required.

You can get the installer here: https://software.intel.com/en-us/articles/opencl-drivers

If you do not do
- scientific computation
- physics simulations (hard/soft/rigid body, cloth, fluid, smoke etc.)
- some other number-crunching thing that requires OpenCL

I don't think you will miss that Intel SDK for OpenCL.
Comment 7 Mike Allen 2017-01-05 18:21:54 UTC
(In reply to Buovjaga from comment #6)
> If you do not do
> - scientific computation
> - physics simulations (hard/soft/rigid body, cloth, fluid, smoke etc.)
> - some other number-crunching thing that requires OpenCL
> 
> I don't think you will miss that Intel SDK for OpenCL.

Unfortunately, simulations are what I do for a living. :-(
Comment 8 Mike Allen 2017-01-05 18:25:41 UTC
Also, the particular version of the SDK that I have on my machine doesn't appear to be listed on that site (I had already checked it out). My concern is that it's a requirement for one of my simulation tools (and I haven't got time to uninstall/reinstall each one to find out if it is the reason LibreOffice doesn't work.

Either way, LibreOffice should not hang just because I have an SDK installed - and it certainly shouldn't in applications that do not use OpenCL.
Comment 9 Buovjaga 2017-01-05 18:31:17 UTC
Ok, let's throw it to NEW based on the Ask.LibO thing and the strong suspicion that it is because of the SFK.
Comment 10 Aron Budea 2017-01-05 18:44:38 UTC
Can you check if there's an <user profile>/cache/opencl_devices.log files, and attach it if exists? There's a chance it won't, but you never know...

If we can get the OpenCL driver version, it should be worthy of blacklisting.
Comment 11 Mike Allen 2017-01-05 18:54:27 UTC
Created attachment 130184 [details]
opencl_devices.log file

opencl_devices.log file, as requested.

By default, applications run using the Intel HD 3000 integrated graphics. However, I also tried using the NVIDIA 4200M card with the 64-bit LibreOffice. The hang occurred with both cards.
Comment 12 Mike Allen 2017-01-05 18:56:35 UTC
Created attachment 130185 [details]
opencl_profile.xml

This file was also present, so I'm attaching it just in case.
Comment 13 Mike Allen 2017-01-05 18:58:28 UTC
Thanks for your assistance with this. Let me know if there's anything else I can do to help!
Comment 14 Aron Budea 2017-01-06 00:19:58 UTC
Thanks for the details. So this seems to be a pretty old driver from years ago. While the CPU is old as well, I wonder if current drivers from [1] would work. Release notes only state SSE4.2 support as requirement.

I guess the driver version should be blacklisted in LibreOffice, too.

[1] https://software.intel.com/en-us/articles/opencl-drivers
Comment 15 Mike Allen 2017-01-07 20:52:00 UTC
I see that the status has been changed to NEEDINFO. What more information is needed?
Comment 16 Buovjaga 2017-01-07 20:54:41 UTC
(In reply to Mike Allen from comment #15)
> I see that the status has been changed to NEEDINFO. What more information is
> needed?

Would you be willing to try a driver update as suggested in comment 14?
Comment 17 Mike Allen 2017-01-07 21:07:55 UTC
As I explained in comment 8, I'm reluctant to try updating my OpenCL SDK as I don't want to break whichever product is using it. I don't have time to reinstall every piece of simulation software I use, as I have more pressing concerns right now.

Simply having an outdated SDK should not cause LibreOffice to hang - particularly in applications, such as when Writer and Impress, that supposedly do not use OpenCL.

Incidentally, can you explain why the 32-bit LibreOffice runs just fine, while the 64-bit version hangs? If it's because the 64-but version tries to use my OpenCL driver, while the 32-bit version doesn't, then is there a way I can disable use of OpenCL in the 64-bit version to verify whether that is the actually the cause of the hang? At least then I'd know whether it was worth my time updating the OpenCL SDK when I do get the time...

Thanks for your assistance!
Comment 18 Aron Budea 2017-01-14 03:07:59 UTC
Mike, you're absolutely right the old SDK *should* work with LibreOffice. However things often don't work as they should. (otherwise you wouldn't be reluctant to update your SDK, right?) I can't give you an explanation, as I don't have a similar hardware and software configuration to yours, and can't investigate. And unless there's someone who can, and is willing to do that, this issue will not be investigated.

Fortunately it likely can be fixed without that. We can probably safely disable OpenCL in LibreOffice on systems with that driver version.

Tor, what do you think, could this Intel SDK's OpenCL driver be blacklisted?
Comment 19 Xisco Faulí 2018-01-15 11:25:40 UTC
@Mike,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 20 QA Administrators 2018-07-31 09:38:35 UTC Comment hidden (obsolete)
Comment 21 QA Administrators 2018-09-03 14:56:45 UTC Comment hidden (obsolete)
Comment 22 Buovjaga 2018-10-01 10:34:26 UTC
This is still an issue: https://www.reddit.com/r/libreoffice/comments/9fzhx0/libreoffice_wont_open_6103/
Comment 23 Mike Allen 2018-10-01 12:20:47 UTC
Apologies for the late reply.

I no longer have access to the machine on which I found this problem. If I get a moment or two, I'll try installing OpenCL on a machine on which I have 64-bit LibreOffice installed and will check to see if I'm still encountering the problem.

Thanks for your assistance!
Comment 24 kaya 2018-11-02 06:37:46 UTC Comment hidden (spam)
Comment 25 Devin Hussey 2018-12-10 18:17:28 UTC
Confirmed on a Fujitsu Lifebook P771.

Windows 10 Pro x64 1809, build 17763.134
Intel Core i7-2617M vPro (Sandy Bridge) @ 1.50 GHz
Intel HD Graphics 3000 integrated graphics (maybe our culprit), no secondary card
Intel driver 9.17.10.4459 (latest from Windows Update causes blurry text, and the card does show up as "unsupported")
4 GB RAM
1280x800 display

LibreOffice:
Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: threaded 

When starting it from a clean install (just reinstalled to upgrade to x64), it hangs on a blank screen when running LibreOffice with 40% CPU usage according to Task Manager. Launching Writer causes a silent background process that apparently restarts itself over and over. 

Starting in Safe Mode and disabling hardware acceleration makes things work without issues.

It does appear that OpenGL blacklists the 3000, but OpenCL does not. Perhaps we should blacklist it until we fix it?