Bug Hunting Session
Bug 105087 - Thickness and sizes of dashes/dots in Underline vary according to typeface font in use, rather than remaining constant irrelevant of typeface font in use.
Summary: Thickness and sizes of dashes/dots in Underline vary according to typeface fo...
Status: RESOLVED DUPLICATE of bug 68573
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 58941
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-01-04 04:46 UTC by minutemeter
Modified: 2017-01-05 00:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description minutemeter 2017-01-04 04:46:17 UTC
Description:
A document containing several different fonts of the same size, e.g. 14-point, with everything containing a dotted or dashed underline shows the dots, dashes and thickness of the underline in different sizes for each typeface font.

Steps to Reproduce:
1.Type a familiar sentence or line repeatedly, e.g. "The quick brown fox jumps over the lazy dog."
2. Select All (Ctrl-A), then select a single size, e.g. 14-point, for everything in the document.
3. Assign a different typeface font for each line.
4. Select All (Ctrl-A) again, then select Underline with a unique style (e.g. Dash, Dotted, Dot-Dash, etc.), for everything in the document.
5. You'll notice that for some fonts the dashes, dots and thickness is bigger in size for some fonts than in others.

Actual Results:  
You'll notice that for some fonts the dashes, dots and thickness is bigger in size for some fonts than in others, which show significantly smaller dashes and dots.

Expected Results:
The thickness and size of the dots and dashes making up the underline ideally should be exactly the same size regardless of whatever typeface font is being used.


Reproducible: Always

User Profile Reset: No

Additional Info:
Normal, it's a bug that should be fixed. A major enhancement that can help is to add an additional feature in Format--Character dialog box that allows manual adjustment of Underline thickness and position.



User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 V Stuart Foote 2017-01-05 00:39:23 UTC

*** This bug has been marked as a duplicate of bug 68573 ***