Download it now!
Bug 105132 - Right click to title of undocked sidebar closes sidebar.
Summary: Right click to title of undocked sidebar closes sidebar.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2017-01-05 20:49 UTC by Gülşah Köse
Modified: 2017-09-12 21:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gülşah Köse 2017-01-05 20:49:40 UTC
Description:
Right click to title of undocked sidebar closes sidebar. But view->sidebar is checked still. I don't know the true behavior of that right click but it seems a bug.

Steps to Reproduce:
1. Undock sidebar.
2. Right click to title of sidebar.

Actual Results:  
It closes sidebar

Expected Results:
I don't know true behavior but current behaviour seems wrong. It seems better to me that nothing happens


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Buovjaga 2017-01-13 12:30:17 UTC
Not reproduced. I tried all the different VCL backends.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 2fd88ab1cbb4690a770ca2ca5d66157ec4906a2e
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on January 12th 2016
Comment 2 Buovjaga 2017-01-13 16:08:16 UTC
No repro on

Win 10
Version: 5.4.0.0.alpha0+
Build ID: 3afe82bd63fde41d2a88418fb64e4ff587b05436
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-04_23:42:57
Locale: fi-FI (fi_FI); Calc: group

Ubuntu 16.10
Version: 5.4.0.0.alpha0+
Build ID: 28f50d7e387864bd41a67b2fb78b9c98a708a00e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2017-01-11_01:19:53
Locale: en-US (en_US.UTF-8); Calc: group
Comment 3 Thomas Lendo 2017-09-12 21:56:41 UTC
Can't reproduce.

Version: 6.0.0.0.alpha0+
Build-ID: bc9714fefb2dd2ad55a92aaacb6b246f354ed2c0
CPU-Threads: 4; Betriebssystem:Linux 4.10; UI-Render: Standard; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-09-11_23:29:06
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

Since reporting of this bug was more than a half year ago and the behavior couldn't reproduced, I will close this bug as WORKSFORME.

Feel free to reopen as UNCONFIRMED if it can be reproduced.