Bug 105196 - Hanging when trying to create a new gallery or to view properties of a gallery
Summary: Hanging when trying to create a new gallery or to view properties of a gallery
Status: RESOLVED DUPLICATE of bug 105017
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta1
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-01-08 21:25 UTC by Julien Nabet
Modified: 2017-01-09 10:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2017-01-08 21:25:33 UTC
Description:
On pc Debian x86-64 with master sources updated today, I got a hang when trying to create a new gallery or to view properties of an existing one.
Sidebar can be detached or not, same result.
If Ctrl-C to kill LO and restart LO, the new theme has indeed been created.

I found this giving a try to tdf#105017

Steps to Reproduce:
1. Open Writer
2. Click Gallery on Sidebar
3. Click "New Theme..." button


Actual Results:  
Hangs

Expected Results:
shouldn't hang


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-01-09 08:42:02 UTC
Confirming with:
Version: 5.4.0.0.alpha0+
Build ID: 92a1ad1f36b6d3cc13135a8c0805508933011577
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-06_23:42:59
Locale: nl-NL (nl_NL); Calc: CL

and with
Versie: 5.3.0.0.beta1  (x64)
Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU Threads: 4; Versie besturingssysteem:Windows 6.19; UI Render: standaard; Layout Engine: new; 
Locale: nl-NL (nl_NL); Calc: CL

but not with
Versie: 5.3.0.0.alpha1 
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Julien Nabet 2017-01-09 09:02:00 UTC
Increasing importance since:
- it's a hang
- it's a regression
- always reproduceable
- not specific to 1 platform
- not a corner case
Comment 3 Xisco Faulí 2017-01-09 10:09:39 UTC
I guess this is a dupe of bug 105017...

*** This bug has been marked as a duplicate of bug 105017 ***
Comment 4 Julien Nabet 2017-01-09 10:19:54 UTC
Xisco: it's a bit early to put it as a dup since there's no bt here.
But indeed, I suppose both are related, that's why I put the other in See also.
Comment 5 Xisco Faulí 2017-01-09 10:43:52 UTC
Confirmed that 78b4a1fb01af9ad3b3395a22f6e396be914b553e introduced the hang when clicking on 'new theme'. Before this commit it crashes due to commit eca5ea9f79181d45cd7fbabe2313617d3025818a

*** This bug has been marked as a duplicate of bug 105017 ***