Download it now!
Bug 105202 - GTK+ 3: Tab widget lacks borders and has unnecessary padding
Summary: GTK+ 3: Tab widget lacks borders and has unnecessary padding
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Area-Fill-Tab gtk3-themeing
  Show dependency treegraph
 
Reported: 2017-01-09 09:26 UTC by Trinh Anh Ngoc
Modified: 2020-04-13 19:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (44.41 KB, image/png)
2017-01-09 09:26 UTC, Trinh Anh Ngoc
Details
Screenshot of libreoffice page style (44.86 KB, image/png)
2017-01-15 02:26 UTC, Trinh Anh Ngoc
Details
Screenshot of gtk+ page style (122.58 KB, image/png)
2017-01-15 02:28 UTC, Trinh Anh Ngoc
Details
Native gtk3 in background, emulated in foreground (36.56 KB, image/png)
2017-01-15 09:58 UTC, Heiko Tietze
Details
libreoffice 5.1.2 (102.97 KB, image/png)
2017-01-15 13:50 UTC, Trinh Anh Ngoc
Details
libreoffice tab and gtk+ tab comparison screenshot (74.85 KB, image/png)
2017-08-30 13:21 UTC, Trinh Anh Ngoc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Trinh Anh Ngoc 2017-01-09 09:26:15 UTC
Created attachment 130273 [details]
screenshot

Notebook body (white area in the attached screenshot) lacks border and has unnecessary padding.
Comment 1 Xisco Faulí 2017-01-12 10:02:32 UTC
The padding problem is in Right Click - Edit Style. Adding Ux team for advise...
Comment 2 Heiko Tietze 2017-01-12 14:07:59 UTC
It's likely a result from the changes to the area tab, similar to bug 103225. But even without a fix size and better alignment as requested in bug 105259 the content of the area tab will define the minimum dialog size.
Comment 3 Buovjaga 2017-01-12 15:07:41 UTC
(In reply to Heiko Tietze from comment #2)
> It's likely a result from the changes to the area tab, similar to bug
> 103225. But even without a fix size and better alignment as requested in bug
> 105259 the content of the area tab will define the minimum dialog size.

How could it be related to the changes, when reporter is on 5.2.4?
Comment 4 Heiko Tietze 2017-01-12 15:18:36 UTC
(In reply to Buovjaga from comment #3)
> How could it be related to the changes, when reporter is on 5.2.4?

Good point. I'm apparently primed by white space.
Comment 5 Heiko Tietze 2017-01-14 11:38:02 UTC
I guess with unnecessary padding you mean the white space between the summary text and the bottom? That's a WONTFIX because the dialog size is defined by the controls and when another tab contains more stuff this one defines the minimum width and height. Otherwise the dialog would be resize every time you switch to another tab.

About the border it depends on your desktop environment. In case if Unity the border is not shown anymore. LibreOffice follows the system default.

Setting to NEEDINFO in case I'm wrong.
Comment 6 Trinh Anh Ngoc 2017-01-15 02:26:25 UTC
Created attachment 130445 [details]
Screenshot of libreoffice page style

No, I attached new screenshot, two black lines in the screenshot are unnecessary padding.
Comment 7 Trinh Anh Ngoc 2017-01-15 02:28:55 UTC
Created attachment 130446 [details]
Screenshot of gtk+ page style

Screenshot of gtk+ notebook
Comment 8 Heiko Tietze 2017-01-15 09:58:04 UTC
Created attachment 130449 [details]
Native gtk3 in background, emulated in foreground

Here is how it looks with a built from master. In the background I started LibO in a virtual machine with Ubuntu (default settings with Ambiance theme), the foreground is my host with LXQt and Breeze-gtk emulation of Gtk apps. And I get exactly your result when I set the default style to Emacs. So my guess is that you run a Qt based desktop environment (KDE) and use this setting at System Setting > Application Style > Gnome Application Style > Gtk Themes.
Comment 9 Trinh Anh Ngoc 2017-01-15 10:07:34 UTC
No, i am using GNOME 3.22 on ArchLinux.
Comment 10 Heiko Tietze 2017-01-15 11:51:20 UTC
(In reply to Trinh Anh Ngoc from comment #9)
> No, i am using GNOME 3.22 on ArchLinux.

What theme do you run? And what happens when you chance it? 

https://wiki.archlinux.org/index.php/GNOME#GTK.2B_themes_and_icon_themes
Comment 11 Trinh Anh Ngoc 2017-01-15 13:40:51 UTC
I use default theme (Adwaita). I tried Numix theme and saw same problem.
Comment 12 Trinh Anh Ngoc 2017-01-15 13:50:05 UTC
Created attachment 130450 [details]
libreoffice 5.1.2

Seem be a regression. On LibreOffice 5.1.2 (Fedora 24), page style has full border. It still has unnecessary padding, though.
Comment 13 Heiko Tietze 2017-01-15 14:22:43 UTC
Hm, I bet it's a regression of your theme. Setting to UNCONFIRMED for the QA experts. Design wise the system theme has to be respected. Not more to advice here.
Comment 14 Trinh Anh Ngoc 2017-08-30 13:21:56 UTC
Created attachment 135871 [details]
libreoffice tab and gtk+ tab comparison screenshot
Comment 15 Buovjaga 2017-08-30 13:33:48 UTC
(In reply to Trinh Anh Ngoc from comment #14)
> Created attachment 135871 [details]
> libreoffice tab and gtk+ tab comparison screenshot

Repro.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 507247697dc6c4a41fe17a29d522511f97040738
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on August 29th 2017
Comment 16 QA Administrators 2018-09-09 02:39:43 UTC Comment hidden (obsolete)
Comment 17 Xisco Faulí 2020-03-09 13:28:13 UTC
Please add keyword 'needsUXEval' and CC 'libreoffice-ux-advise@lists.freedesktop.org' if input from UX is needed.
Comment 18 Caolán McNamara 2020-04-13 19:34:04 UTC
That particular dialog is now all native gtk3 widgets under GNOME so follows theme correctly now