Bug Hunting Session
Bug 105227 - Sumproduct function in LO 5 breaks compatibility from LO 4
Summary: Sumproduct function in LO 5 breaks compatibility from LO 4
Status: RESOLVED DUPLICATE of bug 91453
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-09 21:56 UTC by Eddy
Modified: 2017-01-09 22:57 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Example of sumproduct formula producing error on text cell (7.89 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-01-09 21:56 UTC, Eddy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eddy 2017-01-09 21:56:44 UTC
Created attachment 130294 [details]
Example of sumproduct formula producing error on text cell

In LibreOffice 4, when a cell used in sumproduct contained text, it was ignored and the sum was done with the values of other cells. The same file in LibreOffice5 produces an error.

See attached file :
cell A1 contains 5
cell B1 contains 8
Cell A2 contains 4
cell B2 contains 2
cell A4 contains formula =SOMMEPROD(A1:B1*A2:B2) (using French local)

This returns value 36 as expected.

If I replace B2 by somme text, for example "-" then cell A4 returns value 20 in LibreOffice 4 (ignoring completely cells B1 and B2) and #VALEUR ! in LibreOffice 5.

Of course there is logic in both behaviours and I can even understand why some might find LO 5 's handling of the situation to be better.

But alas this change renders lots of files (in my case anyway) and make them totally useless. IMO formulas should not be version dependant. Compatibility matters !

Thanks any way for the excellent work and a great office suit.
Comment 1 Mike Kaganski 2017-01-09 22:33:17 UTC

*** This bug has been marked as a duplicate of bug 91453 ***
Comment 2 Eddy 2017-01-09 22:57:10 UTC
Thanks a lot ! Sorry I didn't find bug 91453 before reporting this.