Bug 105230 - Can not type text with multiple slashes; /foo/ become foo in italic
Summary: Can not type text with multiple slashes; /foo/ become foo in italic
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
(earliest affected)
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2017-01-10 07:43 UTC by Jim Avera
Modified: 2017-01-10 23:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2017-01-10 07:43:49 UTC
/text between slashes/ is auto-converted to italic and the slashes disappear. 

This occurs in Writer and Calc (at least).  I'm guessing it is an Accessibility feature to help people who can not easily hold down the CONTROL key and so can't use the usual Control-I to enter italic mode.  However it is extremely annoying and makes it almost impossible to enter /linux/style/path/names/with/forward/slashes (you have to go back and "correct" the text to put the slashes back and un-italicize the text).

I couldn't find any documentation about this, or anything relevant under Tools->Options->LibreOffice->Accessibilty. 

I tried turning off everything in Tools->Options->Writing Aids but the behaviour persisted.

I also tried a new blank profile (Help->Restart in Safe mode >Reset to Factory Settings >Reset User Profile).  This did not stop the behavior.

This is a bug, either altogether or the fact that it is enabled by default (and IMO not documented sufficiently to allow users to turn it off).

NOTE: I see this problem in but NOT 5.2, 5.2, or 5.3, and then it re-appears in the latest master (


1. Start libreoffice -- --writer (version 5.0 OR 5.4/master)
2. Type /foo/bar

RESULTS: The text changes to "foobar" with "foo" italicized

EXPECTED RESULTS: Text is not molested or slashes removed
Comment 1 Jim Avera 2017-01-10 07:52:48 UTC
I'm sorry, I must have been confused.

The problem only appears in master (not 5.3 or before)

Build ID: 6bd7451ecd66417a4e8b8dff3874c15ba4d1536e
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-01-05_23:29:43
Locale: en-US (en_US.UTF-8); Calc: CL
Comment 2 Jacques Guilleron 2017-01-10 10:09:09 UTC
Hi Jim,

I reproduce with 
LO Build ID: 5903235d57acb13d9d5286d23b443a01aeab9a3c
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-19_00:08:35
Locale: fr-FR (fr_FR); Calc: CL
under Windows 7 Home.
A workaround is to first type the two slashes and then enter text between.

Comment 3 Maxim Monastirsky 2017-01-10 10:30:48 UTC
Open Tools > AutoCorrect > AutoCorrect Options... , switch to the Options tab, and uncheck "Automatic *bold* and _underline_".

In addition, AutoCorrect creates separate undo actions, so whenever this happens you can simply undo the last action.
Comment 4 Jim Avera 2017-01-10 23:44:30 UTC
> uncheck "Automatic *bold* and _underline_"\

Ok, but this is still wrong behavior until it conforms to the documentation, which at the moment says absolutely nothing about slashes and italics.

Developers: Please, please PLEASE always update documentation at the same time that you make incompatible changes.  Not doing so unfairly causes extra work for many other people...