Download it now!
Bug 105250 - insert cross-reference: "insert reference to" should remember user selection
Summary: insert cross-reference: "insert reference to" should remember user selection
Status: RESOLVED DUPLICATE of bug 92688
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.3.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fields-Cross-Reference
  Show dependency treegraph
 
Reported: 2017-01-11 03:15 UTC by john
Modified: 2017-06-04 13:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john 2017-01-11 03:15:51 UTC
Description:
In the Fields dialog, in the Cross-references tab (Insert->Cross-reference), one must select what one wishes to reference, eg a bookmark, a heading, a figure, a table or something else.

When working on a large document, there will be different default ways that the user will want to refer to these things, eg for a figure you might want "Category and Number" to reference "Figure 1", but for a bookmark you might want "Chapter" in order to reference "ยง2.2". For an equation, you might want something else again.

It would be ideal if this dialog were able to remember the recent user preference for cross-references of the different types. So that when I insert a Figure reference, I don't need to click "Category and Number" every time.

Note: as of 5.2.3, LO is already quite a bit smarter than it used to be: it remembers the previous reference "type" and the previous "insert reference to". What is suggested here is a small additional refinement.

Steps to Reproduce:
1. Insert reference to a figure (Category and Name)
2. Insert a reference to a bookmark (Chapter)
3. Insert reference to another figure (Category and Name)

Actual Results:  
At step 3, it is necessary to manually select 'Category and Name' again.

Expected Results:
If the "Insert reference to" box could remember what kind of reference was last used for each reference type, then it would save additional clicks.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Buovjaga 2017-01-13 20:06:15 UTC
Sounds fairly reasonable. I don't think anyone would hurt their feelings, if the behaviour was changed. NEW.
Comment 2 Dieter 2017-06-04 12:35:02 UTC
Is this a duplicate of 92688?
Comment 3 Buovjaga 2017-06-04 13:36:52 UTC
Ah, good catch. That's what I get for being too lazy to search for dupes..

*** This bug has been marked as a duplicate of bug 92688 ***