Bug Hunting Session
Bug 105321 - Text kerning is bad depending on point size
Summary: Text kerning is bad depending on point size
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-01-14 02:08 UTC by Aprax
Modified: 2019-05-27 11:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
examples of incorrect (phantom) spacing (12.48 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-01-14 02:08 UTC, Aprax
Details
letter "c" still a problem (67.11 KB, image/png)
2017-02-24 13:05 UTC, Aprax
Details
Screenshot from 5.3, Windows (103.31 KB, image/jpeg)
2017-02-24 13:20 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aprax 2017-01-14 02:08:09 UTC
Created attachment 130412 [details]
examples of incorrect (phantom) spacing

See the attached spreadsheet which shows that characters c and w have additional empty space following, e.g. making "weg" appear as "w eg" when using 8 point formatting.
Similarly, c has empty space following for both 8 and 10 point sizes.
Comment 1 Buovjaga 2017-01-23 15:39:18 UTC
It seems this might be fixed with the new font layout engine of 5.3.
Could you please test 5.3: http://www.libreoffice.org/download/pre-releases/

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED FIXED, if the problem went away.
Comment 2 Aprax 2017-02-24 13:03:44 UTC
5.3.0.3 64 bit fixes the letter "w" but the letter "c" is still a problem, see screenshot...
Comment 3 Aprax 2017-02-24 13:05:23 UTC
Created attachment 131443 [details]
letter "c" still a problem
Comment 4 Buovjaga 2017-02-24 13:20:17 UTC
Created attachment 131444 [details]
Screenshot from 5.3, Windows

I don't see the kerning problem. I have ClearType enabled in Windows.
Comment 5 Johnny_M 2017-08-10 12:25:58 UTC
This could be another duplicate of the bug 88991 (the root cause being the bug 103322).
Comment 6 Aprax 2017-09-30 11:04:54 UTC
still a problem in 5.3.6.1 with W7x64
Comment 7 Aprax 2018-03-06 14:36:08 UTC
still bad in V6.0.2.1
Comment 8 Xisco Faulí 2018-11-27 15:02:18 UTC
Hello Aprax,
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 9 QA Administrators 2019-05-27 02:46:19 UTC Comment hidden (obsolete)
Comment 10 Aprax 2019-05-27 11:34:35 UTC
in v 6.2.2.2 it's now working properly for all the fonts that I've checked so someone inadvertently fixed it without updating this ticket/report.
So I'd say it "Resolved" "Fixed" is the correct status.
Comment 11 Xisco Faulí 2019-05-27 11:46:08 UTC
(In reply to Aprax from comment #10)
> in v 6.2.2.2 it's now working properly for all the fonts that I've checked
> so someone inadvertently fixed it without updating this ticket/report.
> So I'd say it "Resolved" "Fixed" is the correct status.

Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.