Download it now!
Bug 105333 - UX: A table can't be cut and paste fully (the source table stays behind)
Summary: UX: A table can't be cut and paste fully (the source table stays behind)
Status: RESOLVED DUPLICATE of bug 84806
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2017-01-14 09:29 UTC by Telesto
Modified: 2017-02-04 13:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (9.03 KB, application/3dr)
2017-01-15 08:52 UTC, Telesto
Details
Screencast (490.00 KB, video/x-msvideo)
2017-01-27 11:50 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-01-14 09:29:22 UTC
Description:
In Word and Google docs a a table can't be cut and paste completely (deleting the original table). In LibO it's only the content of the table. It's probably a matter of taste. 

Steps to Reproduce:
1.Open attached file
2. Cut the table
3. Past it somewhere else (same document or different document)

Actual Results:  
The source table will stay behind

Expected Results:
1. The source table gets deleted by default (as quite common)
2. An option to set the personal preference (personal preference, but probably to complex)



Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.0.alpha0+
Build ID: 88f561204d7cee25633df8117cc8d7e1ebd8e9ad
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-11_23:07:37
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Regina Henschel 2017-01-14 21:20:28 UTC
Do not use "Select whole Table" but select from end of paragraph before the table to start of paragraph after the table. That is a workaround. I too think, that an additional item "Cut table" would be good.
Comment 2 Telesto 2017-01-15 08:52:52 UTC
Created attachment 130447 [details]
Example file

A situation where it is more a bit problematic (because of a missing paragraph)
1. Open attached file
2. Try to cut the table within the table cell and paste it somewhere else. (Source table will stay behind)
Comment 3 Heiko Tietze 2017-01-27 10:11:46 UTC
You have to include the paragraph before and after the table in order to cut (and delete) it. LibreOffice works here like GDoc and, IIRC, MS Word. So this is a WFM. If you miss the paragraph before the table you can press Alt+Enter in the first cell (top-left) (see also bug 51689). Doing so allows to easily cut the embedded table in your example.

The additional menu entry "Select table paragraph" is a WF for me as it confuses the user with "Select table". We could think about changing the function that it includes the paragraph before and after. But I wouldn't do so since we may need to add the preceding linefeed automatically.

Keeping the ticket open for a while to get more opinions (NI for myself).
Comment 4 Telesto 2017-01-27 11:50:40 UTC
Created attachment 130717 [details]
Screencast

@Heiko Tietze
About: You have to include the paragraph before and after the table in order to cut (and delete) it. LibreOffice works here like GDoc and, IIRC, MS Word. 

-> I disagree: example video
Comment 5 Heiko Tietze 2017-01-29 12:48:15 UTC
(In reply to Telesto from comment #4)
>> You have to include the paragraph before and after the table in order
>> to cut (and delete) it. LibreOffice works here like ... MS Word. 

Okay, so MS Word cuts the table. I believe our approach is better since you can easily cut or delete the full content from a table without destroying the organization (cells).

@Stuart, Jay, Adolfo: Opinions?
Comment 6 V Stuart Foote 2017-01-29 16:11:49 UTC
Current work-around behavior of including the preceding Paragraph marker with table selection to be able to fully Cut the Table object to clip-board needs attention. It is effective but not obvious UI.

Existing handling of Table objects selection and Copy/Paste or Cut/Paste retaining the formatted but empty Table framework behind remains an appropriate default. 

Existing "Copy" of selected table seems correct.

Beleive a new uno: command to "Cut a Table" (i.e. action to select table & the preceeding/trailing paragraph end marks if required for ODF compliance to clipboard) is needed.

And if needed adjust the "Paste", or provide a "Paste a Table" action, to correctly place the copied or cut table object onto the document.

Commands would be resident on Table toolbar, and the menus--and probably should receive global short-cut assignment.
Comment 7 Yousuf Philips (jay) (retired) 2017-02-04 13:20:27 UTC

*** This bug has been marked as a duplicate of bug 84806 ***