Bug 105343 - Select a table row isn't working properly when starting with a row containing a table within
Summary: Select a table row isn't working properly when starting with a row containing...
Status: RESOLVED DUPLICATE of bug 47979
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Select
  Show dependency treegraph
 
Reported: 2017-01-14 20:10 UTC by Telesto
Modified: 2022-10-13 13:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (9.85 KB, application/3dr)
2017-01-14 20:10 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-01-14 20:10:18 UTC
Description:
Selecting a table row isn't working properly if the selection starts at a row, containing a cell with a table. It's working correctly when starting from row 6 up to row 1.

Steps to Reproduce:
1.Open attached file
2. Move the mouse cursor near left table border "Select table row" will popup.
3. Try to select row 1-5 with dragging alongside the table rows (by pressing down the left mouse button and dragging towards table bottom. 


Actual Results:  
The both row of the left column of the table within the row will be selected. 


Expected Results:
The row containing the table should be selected


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in:
Version: 5.4.0.0.alpha0+
Build ID: 88f561204d7cee25633df8117cc8d7e1ebd8e9ad
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-11_23:07:37
Locale: nl-NL (nl_NL); Calc: CL

and in
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-01-14 20:10:37 UTC
Created attachment 130438 [details]
Example file
Comment 2 Buovjaga 2017-01-23 16:49:35 UTC
Repro with file.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 63fd4c97118a943c84ba5a666cf8c9cc54b511c7
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on January 22th 2016
Comment 3 Ulrich Windl 2017-10-19 08:07:24 UTC
I also have this problem (5.3.6.1). Selecting table rows should be possible starting from any row, moving the mouse in any direction (i.e.: up or down), not just starting from first row down.
For motivation: I think this worked in Microsoft Work for Windows v1.2 about 25 years ago ;-)
Comment 4 QA Administrators 2018-10-20 02:53:17 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2020-10-20 04:20:11 UTC Comment hidden (obsolete)
Comment 6 László Németh 2022-10-13 13:14:17 UTC
@Telesto & all: thanks for the bug report and your other feedback!

The problem is solved by the fix for Bug 151478 (which was only selecting by using the Table menu).

*** This bug has been marked as a duplicate of bug 47979 ***