Download it now!
Bug 105392 - FILEOPEN: DOCX: SAXParseException in footer
Summary: FILEOPEN: DOCX: SAXParseException in footer
Status: RESOLVED DUPLICATE of bug 104181
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-17 15:32 UTC by Xisco Faulí
Modified: 2017-01-17 21:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-01-17 15:32:46 UTC
This is the follow-up bug of bug 103063.
After 4b3e8de6b3cb971b02aa0cb90aceb9e104071d3b, attachment 127891 [details] doesn't crash anymore, however it prompts the following error:

File format error found at unsatisfied query for interface of type com.sun.star.embed.XRelationshipAccess!
SAXParseException: '[word/footnotes.xml line 2]: unknown error', Stream 'word/footnotes.xml', Line 2, Column 30841
SAXParseException: '[word/document.xml line 2]: unknown error', Stream 'word/document.xml', Line 2, Column 42876(row,col).

Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: 4b3e8de6b3cb971b02aa0cb90aceb9e104071d3b
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Xisco Faulí 2017-01-17 15:34:35 UTC
@Mike: I thought you might be interested on this one as it prompts a SAXParseException error
Comment 2 Mike Kaganski 2017-01-17 20:19:04 UTC
Looks exactly the same as bug 104181: after importing with SAXExceptions ignored, the rest of text after footnote anchor is moved to footnote text.
Comment 3 Xisco Faulí 2017-01-17 21:12:01 UTC
(In reply to Mike Kaganski from comment #2)
> Looks exactly the same as bug 104181: after importing with SAXExceptions
> ignored, the rest of text after footnote anchor is moved to footnote text.

Hi Mike,
thanks for taking a look. I'll close this as RESOLVED DUPLICATED.
Regards

*** This bug has been marked as a duplicate of bug 104181 ***