Download it now!
Bug 105436 - FILEOPEN: incorrect table spacing
Summary: FILEOPEN: incorrect table spacing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Vitaliy
URL:
Whiteboard:
Keywords: bibisectRequest, filter:docx, regression
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2017-01-19 10:00 UTC by Xisco Faulí
Modified: 2017-08-03 10:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
comparison (144.21 KB, image/png)
2017-01-19 10:00 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-01-19 10:00:18 UTC
Created attachment 130551 [details]
comparison

Steps:
1. Open attachment 56375 [details]

Check first and last column.
- Number 13 is not displayed in first column
- Spacing in last column is smaller

Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: 4b3e8de6b3cb971b02aa0cb90aceb9e104071d3b
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 5.4.0.0.alpha0+
Build ID: db4badfc971b9cc60809c3408f579bae04a77c34
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-10_23:25:07
Locale: es-ES (es_ES); Calc: group
Comment 1 MM 2017-01-19 19:33:05 UTC
Unconfirmed with Version: 5.4.0.0.alpha0+
Build ID: ec1afa55e8ed79dc290caff74aaca304a77c3b4f
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-01-14_01:33:36
Locale: en-US (en_US.UTF-8); Calc: single

Confirmed with Version: 5.4.0.0.alpha0+
Build ID: acbcec11940d245aabed93ca756ef9462e06f192
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-01-19_00:42:06
Locale: en-US (en_US.UTF-8); Calc: single
Comment 3 Xisco Faulí 2017-01-19 23:59:42 UTC
hi Vitaliy,
do you think this regression was introduced by your commit 7fa20da88a4778bdf20d6ca0491fe97ae03ab554?
Comment 4 Vitaliy 2017-01-26 09:17:20 UTC
(In reply to Xisco Faulí from comment #3)
> hi Vitaliy,
> do you think this regression was introduced by your commit
> 7fa20da88a4778bdf20d6ca0491fe97ae03ab554?

Please try to disable the MS Word comp. option in Tools->Options->LibreOffice Writer->Compatibility
It disables my changes in the text formatting
Comment 5 Vitaliy 2017-01-26 09:37:02 UTC
Xisco Faulí just remove one of two line breaks in the start
Comment 6 Vitaliy 2017-01-26 10:01:05 UTC
yes it is a bug. The Ms Word hasn't two line breaks in start. I take it to solving
Comment 7 Mike Kaganski 2017-01-26 13:18:49 UTC
[offtopic]

The problem is indeed there, that needs to be fixed; it's that line spacing isn't imported correctly.
But what a pain to see such formatted documents! I feel sympathy to those brave people who dare to create and work with such piece of art.
Comment 8 Xisco Faulí 2017-01-27 10:36:52 UTC
I can no longer reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: b41186a2fc49e440890b8c86e5367352ffaf9cd6
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-26_01:50:40
Locale: es-ES (es_ES); Calc: group

Problem was introduced by  https://cgit.freedesktop.org/libreoffice/core/commit/?id=2757ee9fe610e253e4ccc37423fa420004d0f388 and fixed in https://cgit.freedesktop.org/libreoffice/core/commit/?id=00aa9f622c29aecc6bb9c5ee4b3aa35a9afb095d

Thanks to Vitaliy for investigating it.

Closing as RESOLVED FIXED