Bug Hunting Session
Bug 105437 - Tabs in triple tab dialogs show inconsistent rounded edge behaviour
Summary: Tabs in triple tab dialogs show inconsistent rounded edge behaviour
Status: RESOLVED DUPLICATE of bug 103896
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-01-19 10:15 UTC by Alex Thurgood
Modified: 2017-01-23 08:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Tabbed rounding behaviour - video screenshot (858.89 KB, video/quicktime)
2017-01-19 10:22 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2017-01-19 10:15:32 UTC
Description:
Some dialogs with only three tabs show inconsistent rounded edge behaviour.

The first tab (left hand side - LHS) only has rounded right hand side (RHS) corners/edges when unselected. When it is selected after switching from another tab, the round edges appear on the LHS of the tab.

The middle tab has straight edges/corners whether selected or unselected.

The third tab (RHS) has rounded corners on the RHS when selected but square edge corners when unselected.

Steps to Reproduce:
1. Open a new Writer document
2. Tools > Macros > Organize Macros > LibreOffice Basic
3. Click on the Organize button
4. A 3-tab dialog window is displayed. By default, the first tab is selected, and the corners on the LHS of that tab are rounded, whereas the RHS corners are square. The other two tabs have square corners.
5. Click on the middle tab - the edges remain square, however, the 1st tab now has rounded RHS corners.
6. Click on the 3rd tab - the RHS corners are now rounded, whereas the LHS corners are square

Actual Results:  
The tabs display inconsistent rounding behaviour leading to an unfinished UI experience

Expected Results:
The corners should either be all rounded, or all square, to be consistent


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Alex Thurgood 2017-01-19 10:22:56 UTC
Created attachment 130552 [details]
Tabbed rounding behaviour - video screenshot
Comment 2 Alex Thurgood 2017-01-19 10:26:00 UTC
Seems to be already present in 

Version: 5.2.3.3
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
Threads CPU : 2; Version de l'OS :Mac OS X 10.12.2; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 3 Alex Thurgood 2017-01-19 10:31:14 UTC
In
Version: 5.1.6.2
Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
Threads CPU : 2; Version de l'OS :Mac OS X 10.12.2; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

the rounding is done correctly, only the outside edges are rounded on the outermost tabs, whether selected or unselected.
Comment 4 Telesto 2017-01-21 19:57:03 UTC
Looks a bit like a dupe: bug 103896
Comment 5 Alex Thurgood 2017-01-23 08:36:33 UTC
@Telesto : thanks, well spotted, yes, a DUP in indeed.

*** This bug has been marked as a duplicate of bug 103896 ***