Bug 105448 - i18n: add Manchu and Sibe to language list
Summary: i18n: add Manchu and Sibe to language list
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Eike Rathke
QA Contact:
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on: 62154 HarfBuzz
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-20 11:34 UTC by Volga
Modified: 2017-03-15 17:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2017-01-20 11:34:03 UTC
Description:
The OpenType specification has a large set of language tags covering many of languages in the world, and a small number of them have been changed when the new version of spec is releasesd. They can be used for some language specific features definded in OT fonts. However some of them are not available in LibreOffice.

Recent versions of HarfBuzz have some improvements for language tags to follow OT spec, we should add more languages in LibreOffice to cover language tags defined in HaefBuzz, at least making them available at Character dialog. Also, if OT spec made  minor changes for language tags, and HarfBuzz follow that, we should also follow that revision.

Steps to Reproduce:
-

Actual Results:  
-

Expected Results:
-


Reproducible: Always

User Profile Reset: No

Additional Info:

See:
OT language tags
https://www.microsoft.com/typography/otspec/languagetags.htm
OT spec changes log file
https://www.microsoft.com/typography/otspec/changes.htm


User-Agent: Mozilla/5.0 (Android 4.3; Mobile; rv:51.0) Gecko/51.0 Firefox/51.0
Comment 1 Khaled Hosny 2017-01-20 14:57:32 UTC
You can already use any BCP47 language tag in LibreOffice.
Comment 2 Volga 2017-01-20 15:02:28 UTC
(In reply to Khaled Hosny from comment #1)
> You can already use any BCP47 language tag in LibreOffice.

Oh, how can I use them for Manchu and Sibe?
Comment 3 Khaled Hosny 2017-01-20 15:59:49 UTC
(In reply to Volga from comment #2)
> (In reply to Khaled Hosny from comment #1)
> > You can already use any BCP47 language tag in LibreOffice.
> 
> Oh, how can I use them for Manchu and Sibe?

Where do you want to use them?
Comment 4 Volga 2017-01-20 18:40:20 UTC
(In reply to Khaled Hosny from comment #3)
> (In reply to Volga from comment #2)
> > (In reply to Khaled Hosny from comment #1)
> > > You can already use any BCP47 language tag in LibreOffice.
> > 
> > Oh, how can I use them for Manchu and Sibe?
> 
> Where do you want to use them?

Well, they are already has their own language tag in the specification, but they seems not found in Writer, at least in Character dialog.
Comment 5 Khaled Hosny 2017-01-20 21:48:27 UTC
(In reply to Volga from comment #4)
> (In reply to Khaled Hosny from comment #3)
> > (In reply to Volga from comment #2)
> > > (In reply to Khaled Hosny from comment #1)
> > > > You can already use any BCP47 language tag in LibreOffice.
> > > 
> > > Oh, how can I use them for Manchu and Sibe?
> > 
> > Where do you want to use them?
> 
> Well, they are already has their own language tag in the specification, but
> they seems not found in Writer, at least in Character dialog.

You can just type the language code in the Language field.
Comment 6 Volga 2017-01-21 09:38:44 UTC
(In reply to Khaled Hosny from comment #5)
> (In reply to Volga from comment #4)
> > (In reply to Khaled Hosny from comment #3)
> > > (In reply to Volga from comment #2)
> > > > (In reply to Khaled Hosny from comment #1)
> > > > > You can already use any BCP47 language tag in LibreOffice.
> > > > 
> > > > Oh, how can I use them for Manchu and Sibe?
> > > 
> > > Where do you want to use them?
> > 
> > Well, they are already has their own language tag in the specification, but
> > they seems not found in Writer, at least in Character dialog.
> 
> You can just type the language code in the Language field.
Oh, where to find the field?
Comment 7 Eike Rathke 2017-01-25 13:19:08 UTC
Format Font Language is an edit field that accepts any valid BCP47 language tag.
Comment 8 Volga 2017-01-25 17:05:43 UTC Comment hidden (obsolete)
Comment 9 Volga 2017-01-25 17:07:59 UTC
(In reply to Volga from comment #0)
> Recent versions of HarfBuzz have some improvements for language tags to
> follow OT spec, we should add more languages in LibreOffice to cover
> language tags defined in HaefBuzz, at least making them available at
> Character dialog. 
Sorry for my bad English. I thought these languages should be available via Language listbox at Character dialog at least.
Comment 10 Eike Rathke 2017-01-25 20:35:00 UTC
We won't add 7874 languages to that listbox..

For specific requests please follow https://wiki.documentfoundation.org/LibreOffice_Localization_Guide/Adding_a_New_Language_or_Locale#Request_a_new_language.2Flocale_to_be_added

However, I can take this ticket here to add Manchu and Sibe, as you explicitly mentioned them.
Comment 11 Eike Rathke 2017-01-26 13:20:27 UTC
Though I'm hesitating to add these.. or at least Manchu. It's listed as a nearly extinct language, with a population of 20 and "some additional semi-speakers in 3 remote villages", https://www.ethnologue.com/language/mnc
Is there any compelling reason to have it listed?

Similar for Sibe with a population of 6000, but it may be a bit different because it's listed as statutory language at https://www.ethnologue.com/language/nco
Comment 12 Volga 2017-01-26 21:13:28 UTC
In PRC there is several communities for Manchu language and culture exsited on the Internet, one notable site is Manchu Online (满族在线, http://www.manjusa.com), on this site I found there are so many discussions and sharings about Manchu language, it seems to me that some Manchu people in there have interests in reviving Manchu language even if many of them do not speak Manchu language natively, also, on this site I found a post about LibreOffice. At this point I think maybe we should provide a way to allow Manchu language to be used not only in a document but also for grammer checking if others want to create an extension for this.
Comment 13 Commit Notification 2017-01-30 16:35:25 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=608b749f27a38c267b599968e60dd87bbd9abde6

tdf#105448 add Manchu [mnc-CN] to language list (CTL)

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2017-01-30 16:35:30 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f67061be4f4dde9d5050b48a19ea71a1fc263a7f

tdf#105448 add Sibe [nco-PG] to language list

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Volga 2017-01-31 00:46:19 UTC
Is it possible to backport to 5.3?
Comment 16 Eike Rathke 2017-02-01 11:11:53 UTC
No, we don't add new UI strings to release branches.
Comment 17 Volga 2017-02-25 15:27:09 UTC
(In reply to Eike Rathke from comment #11)
> Similar for Sibe with a population of 6000, but it may be a bit different
> because it's listed as statutory language at
> https://www.ethnologue.com/language/nco

I don’t mentioned a language in Papua New Guinea, instead, I mentioned another language used in PR China, which listed at 
https://www.ethnologue.com/language/sjo
Comment 18 Eike Rathke 2017-02-27 11:50:43 UTC
You said Sibe, not Xibe, so..
Comment 19 Eike Rathke 2017-02-27 11:54:04 UTC
I guess you're talking about Xibe in Mongolian script then?
Comment 20 Volga 2017-03-09 22:43:41 UTC
(In reply to Eike Rathke from comment #19)
> I guess you're talking about Xibe in Mongolian script then?

Yes, I thought I have not noticed it to you timely, sorry for late response.
Comment 21 Volga 2017-03-12 17:21:46 UTC
This language is also statutory in Qapqal, Xinjiang, PR China, and this language is also known as Sibe sometimes, so may have confusion sometimes. BTW would you like to making correction for this?
Comment 22 Commit Notification 2017-03-15 17:52:36 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0d86cff2b3314576c6cb857da06d6b6d217f89b

tdf#105448 add Xibe [sjo-CN] to language list (and remove Sibe [nco-PG])

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.