Bug Hunting Session
Bug 105463 - Checkbox in Base form corrupted
Summary: Checkbox in Base form corrupted
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.3.0.1 rc
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.2
Keywords: bibisected, bisected, regression
: 106150 106235 106824 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-01-21 11:26 UTC by Gerhard Schaber
Modified: 2017-08-24 15:39 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample form (11.08 KB, application/vnd.sun.xml.base)
2017-01-21 11:26 UTC, Gerhard Schaber
Details
test file (10.49 KB, application/vnd.oasis.opendocument.database)
2017-01-31 20:14 UTC, Julien Nabet
Details
screenshot (77.10 KB, image/jpeg)
2017-03-18 08:44 UTC, Ulf
Details
Screenshot of test file with 2D and 3D checkbox displays (14.88 KB, image/png)
2017-03-29 15:31 UTC, Alex Thurgood
Details
Screenshot of flat and 3D checkbox, gtk2, 5.3 nightly (206.24 KB, image/png)
2017-03-29 16:11 UTC, pierre.sauter
Details
Screenshot of checkboxes, gtk3, 5.3.2.2 Ubuntu PPA (155.75 KB, image/png)
2017-04-04 16:10 UTC, pierre.sauter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Schaber 2017-01-21 11:26:07 UTC
Created attachment 130593 [details]
Sample form

Not sure, if this is the same as 104955.

Open the attached file in 5.3.0RC1. In the form, the check box is replaced by a label or so. When you store that accidently, then the checkbox is gone even, if you try to open it in an older LO version (although I cannot reliably reproduce the latter part).

If I create a new checkbox in LO 5.0.6, without any macros and open that in LO 5.3.0RC1, I do not see that issue.

Since it corrupted some of my forms and I had to redo parts of them, I consider that a data loss.
Comment 1 Gerhard Schaber 2017-01-21 11:43:19 UTC
That does not seem to happen with libo-master-2017-01-21_00.59.54_LibreOfficeDev_5.4.0.0.alpha0_Win_x86
Comment 2 Robert Großkopf 2017-01-21 16:40:40 UTC
Could confirm the buggy behavior.
Open a form in a database - you don't need any table.
Create a checkbox.
Label will be written, checkbox doesn't exist any more.

Doesn't work in LO 5.3.0.2, works in LO 5.2.4.2

All tested here with OpenSUSE 42.1 64bit rpm Linux.
Comment 3 Alex Thurgood 2017-01-23 12:44:03 UTC

*** This bug has been marked as a duplicate of bug 104955 ***
Comment 4 Robert Großkopf 2017-01-23 14:52:59 UTC
(In reply to Alex Thurgood from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 104955 ***

Don't think this bug is a duplicate. Original bugreport here about checkboxes in  is about standalone-checkboxes. This I could confirm with LO 5.3.0.2, but not, for example, with LO 5.4.0.0.alpha0+ Time: 2017-01-19_23:59:27.

Checkboxes, which are created in flat-format, disappear.
Checkboxes, which are created as 3D, will be shown.

The other report is about checkboxes in a tablecontrol. This I could never reproduce.

All tested with OpenSUSE 42.1, 64bit rpm Linux.
Comment 5 Gerhard Schaber 2017-01-23 15:23:46 UTC
By the way, with this example, the checkbox is functional in normal mode, but is invisible in edit mode when using libo-master-2017-01-21_00.59.54_LibreOfficeDev_5.4.0.0.alpha0_Win_x86.
Comment 6 Robert Großkopf 2017-01-23 16:07:59 UTC
(In reply to Gerhard Schaber from comment #5)
> By the way, with this example, the checkbox is functional in normal mode,
> but is invisible in edit mode when using
> libo-master-2017-01-21_00.59.54_LibreOfficeDev_5.4.0.0.alpha0_Win_x86.

Do I understand right: You could reproduce the bug also in 5.4.0.0 2017-01-21?
I have downloaded now 5.4.0.0 2017-01-22_23:06:33 for Linux rpm 64bit. Couldn't reproduce the buggy behavior. Checkbox is shown while editing the form nd also shown during input data.
Comment 7 Gerhard Schaber 2017-01-23 16:20:48 UTC
In 5.4 in design mode the checkbox is invisible, in normal mode it is visible and functional.

In 5.3 it is not even functional in normal mode (only a text fragment is visible).
Comment 8 Alex Thurgood 2017-01-24 10:01:04 UTC
Confirmed by Robert, setting to NEW
Comment 9 Alex Thurgood 2017-01-27 09:58:52 UTC
@Gerhard, I get lots of errors when attempting to open the form on OSX LO5302b2, it complains about a missing Lehrgang table, and if I try clicking on what I can see in the form, I get a Basic macro error message. Is this normal ?
Comment 10 Alex Thurgood 2017-01-27 10:01:50 UTC
The Basic macro error is :

A Scripting Framework error occurred while running the Basic script vnd.sun.star.script:GSCLib.Module1.UpdateFromPrfgCheckbox?language=Basic&location=document.

Message: The following Basic script could not be found:
library: 'GSCLib'
module: 'Module1'
method: 'UpdateFromPrfgCheckbox'
location: 'document'
Comment 11 Alex Thurgood 2017-01-27 10:09:30 UTC
OK, I opened the form in Edit mode and can confirm that adding a checkbox with a FLAT attribute cause it not to be displayed when the form is saved, and then re-opened for data entry.
Comment 12 Alex Thurgood 2017-01-27 10:11:31 UTC
Tested against 

Version: 5.3.0.2
Build ID: 5ad7b2889021c491af62f7930a4b1cb631392f16
CPU Threads: 2; OS Version: Mac OS X 10.12.2; UI Render: default; Layout Engine: new; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group
Comment 13 Julien Nabet 2017-01-31 20:14:13 UTC
Created attachment 130805 [details]
test file

On pc Debian x86-64 with master sources updated today + enable-dbgutil + gtk3, I don't reproduce this but perhaps missed something.
Anyway, I created a brand new odb file (hsqlembedded) with no tables and queries.
Just 1 form with 2 CB (checkboxes):
- 1 with flat attribute
- 1 with 3D attribute
Both are functionnal in design or normal view.
Comment 14 Robert Großkopf 2017-01-31 20:38:26 UTC
(In reply to Julien Nabet from comment #13)
> On pc Debian x86-64 with master sources updated today + enable-dbgutil +
> gtk3, I don't reproduce this but perhaps missed something.
> Anyway, I created a brand new odb file (hsqlembedded) with no tables and
> queries.
> Just 1 form with 2 CB (checkboxes):
> - 1 with flat attribute
> - 1 with 3D attribute
> Both are functionnal in design or normal view.

You are right, works with LO 5.4.0.0 from 2017-01-30.

But it fails with 
Version: 5.3.1.0.0+
Build ID: c9ab894ae846185a0341656922b0aa1632bfe886
CPU Threads: 4; OS Version: Linux 4.1; UI Render: default; VCL: kde4; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-3, Time: 2017-01-23_00:14:42
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 15 Gerhard Schaber 2017-01-31 20:55:57 UTC
I can also confirm that 5.4 behaves correctly, now. It would be great to have those fixes in 5.3 as well.
Comment 16 JD 2017-02-07 04:49:15 UTC
I can confirm the same problem as a regression.
Everything runs/looks fine in version 5.2.4. However in version 5.3.0.3 the Boolean Checkbox fields have disappeared from forms and in a table view the columns are listed but the fields are empty. A table Control in a form seems to function correctly. The Option Button Control has the same problem. 
Changing from a flat button display to a 3D display solves check box control problems but there does not appear to be any workaround for the Table views.

Windows 10 (x64)
Comment 17 Stang 2017-02-07 06:20:08 UTC
Linux Mint 18

Seeing similar problem as JD using v5.3.0.3 except no problem with tables.

Views will return if field property Style is changed from "Flat" to "3D".

Same effect with Option Button as with Checkbox.
Comment 18 tim 2017-02-07 21:51:20 UTC
I have the same problem.  On Ubuntu 16.10 and Windows 10 (both 5.3.0.3) I saw no check box at all for a pre-existing box.  

To create a new one under Ubuntu, after one attempt I then couldn't find it in the normal Control toolbar, but it was hidden with others under the 'design mode' icon in the 'form controls' icon.  I then got a strange icon when I created a new check box, and it did not function at all.  

This is new since at least 5.2.2 and possibly later.
Comment 19 tim 2017-02-23 16:11:19 UTC
Just to say this is still an issue for me in Version: 5.3.1.1
Build ID: 1:5.3.1~rc1-0ubuntu1~yakkety0

I've set all my checkboxes to 3D, which seems to help.
Comment 20 Robert Großkopf 2017-02-24 14:50:52 UTC
*** Bug 106150 has been marked as a duplicate of this bug. ***
Comment 21 Alex Thurgood 2017-03-02 09:25:25 UTC
*** Bug 106235 has been marked as a duplicate of this bug. ***
Comment 22 Ulf 2017-03-18 08:44:36 UTC
Created attachment 131981 [details]
screenshot

tableview
Comment 23 Aron Budea 2017-03-19 00:02:00 UTC Comment hidden (bibisection)
Comment 24 Aron Budea 2017-03-19 00:04:08 UTC
Reverse bibisect pointed to the fixing commit(s ?) referenced below. Caolán, could this be backported to 5.3?

https://cgit.freedesktop.org/libreoffice/core/commit/?id=59ad262ab97c497c3e8a24d2e4a65b38f1d1dbec
author		Caolán McNamara <caolanm@redhat.com>	2017-01-04 18:47:55 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2017-01-04 20:34:55 (GMT)

"last bitmaps that pMaskColor arg was used on converted to true transparency"

Note that until a few commits before, in attachment 130593 [details] there was a "P" instead of the checkbox. With the below commit that disappeared, and then a few commits later, starting with the above commit the checkbox is shown correctly.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a3c4f39868226151b4b01906cbcf1b6d40740a28
author		Caolán McNamara <caolanm@redhat.com>	2017-01-04 18:33:36 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2017-01-04 20:34:55 (GMT)

"convert these mono versions to png"
Comment 25 Caolán McNamara 2017-03-22 11:49:51 UTC
This stopped working initially with...

commit c3043a3072465c489d3b20991b17d222771305eb
Author: Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
Date:   Mon Oct 31 13:28:26 2016 +0100

    tdf#103591 icon theme name resolving, ui fixes, prioritize png
Comment 26 Caolán McNamara 2017-03-22 11:56:01 UTC
So, bmps aren't seen only pngs, so need the two commits that moved those old bmps to pngs

submitted to gerrit as https://gerrit.libreoffice.org/#/c/35534/
Comment 27 Commit Notification 2017-03-22 14:55:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2fd3d2256096b6cb3565fbeeb9342c9b983a4018&h=libreoffice-5-3

Resolves: tdf#105463 convert bmps to png

It will be available in 5.3.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Alex Thurgood 2017-03-28 15:57:58 UTC
*** Bug 106824 has been marked as a duplicate of this bug. ***
Comment 29 pierre.sauter 2017-03-29 12:20:37 UTC
The bug still is present in the latest daily 5.3 build for me.

Version: 5.3.3.0.0+
Build ID: 1c5d8ea51f9da89d76b2b2d3bb896225a6ac9dca
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: kde4; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-3, Time: 2017-03-29_09:38:53
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 30 Julien Nabet 2017-03-29 12:38:33 UTC
(In reply to pierre.sauter from comment #29)
> The bug still is present in the latest daily 5.3 build for me.
> ...
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux) and give a new try?
Comment 31 pierre.sauter 2017-03-29 13:06:59 UTC
Did that already, does not help.
Comment 32 Julien Nabet 2017-03-29 14:48:24 UTC
@Pierre Sauter: thank you for your feedback
To know if it concerns only kde, could you test this:
1) "export SAL_USE_VCLPLUGIN=gtk3" (or gtk if you don't use gtk3)
2) then launch LO and check again
?
Comment 33 Alex Thurgood 2017-03-29 15:21:11 UTC
WFM in

Version: 5.3.3.0.0+
Build ID: 1c5d8ea51f9da89d76b2b2d3bb896225a6ac9dca
CPU Threads: 8; OS Version: Mac OS X 10.12.3; UI Render: default; Layout Engine: new; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:libreoffice-5-3, Time: 2017-03-29_08:30:28
Locale: fr-FR (fr_FR.UTF-8); Calc: group
Comment 34 Alex Thurgood 2017-03-29 15:28:41 UTC
However, note that the bounding box isn't drawn, so it isn't completely fixed after all.
Comment 35 Alex Thurgood 2017-03-29 15:31:50 UTC
Created attachment 132259 [details]
Screenshot of test file with 2D and 3D checkbox displays

The screenshot shows 2 checkboxes in a form from the second ODB test file provided in this bug report. The checkbox on the left is 2D and the bounding box is displayed.

If I open up the same file in a nightly 533, then the bounding box of the 2D checkbox is not displayed, even though the tick mark is.
Comment 36 pierre.sauter 2017-03-29 16:11:55 UTC
Created attachment 132260 [details]
Screenshot of flat and 3D checkbox, gtk2, 5.3 nightly

Not a KDE problem, also present in GTK2.

I was not able to test gtk3. Although I did a complete "apt install gnome" on my test machine (Ubuntu 16.04 LTS), the about window only shows "VCL: gtk2" with SAL_USE_VCLPLUGIN=gtk3.
Comment 37 Commit Notification 2017-03-29 17:29:58 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=10fc6e968827d6ce0cbe8517d7e39e2435ef4680&h=libreoffice-5-3-2

Resolves: tdf#105463 convert bmps to png

It will be available in 5.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 38 Adolfo Jayme 2017-03-30 03:22:26 UTC
(In reply to pierre.sauter from comment #36)
> I was not able to test gtk3. Although I did a complete "apt install gnome"

Because that’s not how you install the relevant package here, which is “libreoffice-gtk3”.
Comment 39 pierre.sauter 2017-03-30 12:52:14 UTC
(In reply to Adolfo Jayme from comment #38)
> Because that’s not how you install the relevant package here, which is
> “libreoffice-gtk3”.

I just thought I was missing some gtk3 libs. But as it turns out, nightlies are built with "--disable-gtk3":
http://dev-builds.libreoffice.org/daily/libreoffice-5-3/Linux-rpm_deb-x86_64@70-TDF/current/libreoffice-5-3~2017-03-30_11.34.28_build_info.txt
Comment 40 tim 2017-03-31 07:54:03 UTC
Fixed for me in Version: 5.3.2.2
Build ID: 1:5.3.2~rc2-0ubuntu1~yakkety0
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: x11; Layout Engine: new; 
Locale: en-GB (en_GB.UTF-8); Calc: group

Thanks.
Comment 41 Julien Nabet 2017-03-31 08:02:03 UTC
If there's any remnant buggy behaviour about this, I think it could be useful to create a new bugtracker without forgetting to provide rendering (gtk2, gtk3, kde, ...)
Comment 42 pierre.sauter 2017-04-04 16:10:48 UTC
Created attachment 132334 [details]
Screenshot of checkboxes, gtk3, 5.3.2.2 Ubuntu PPA

@Julian:
The VCL render mode on Linux doesn't change anything. As per comment #35 the flat bounding box is also not drawn in 5.3 on OSX. Has anyone confirmed that the bug is fixed on Windows in 5.3?

@tim:
Do you see the flat bounding box? It is not drawn in the same build for xenial.

@Adolfo:
Did you change the bug status on purpose? I will revert to REOPENED as its not fixed on Linux and OSX for 5.3.
Comment 43 JD 2017-04-18 23:36:54 UTC
Verified as corrected in 5.3.2.2 under Windows 10.
Comment 44 Caolán McNamara 2017-05-30 14:29:15 UTC
https://gerrit.libreoffice.org/#/c/38223/ may fix the outstanding issue
Comment 45 pierre.sauter 2017-08-24 15:39:58 UTC
As I reopened I feel obliged to close it again. Its fixed in 5.4 and is out now :-)