Bug 105483 - Default value of GreekCharStyle should be '2'.
Summary: Default value of GreekCharStyle should be '2'.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-23 04:45 UTC by john
Modified: 2017-01-27 06:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john 2017-01-23 04:45:18 UTC
Description:
Referring to bug 52225, a change was made some years ago which misguidedly changed the default format of Greek letters in equations from italic to roman script. Recently, an 'expert configuration' setting change was made which implements a customisation that allows the correct  behaviour to be restored. However the default behave remains the wrong one -- a new installation of LibreOffice continues to provide non-italic Greek letters in all formulae.

The default value of GreekCharStyle should be changed to 2 -- italics for lower case greek letters, non-italic for upper case.

This correct behaviour would then be consistent with Word 2010+, Latex and Wikipedia, and is the conventional formatting of most mathematics, science and engineering publications (textbooks, journal papers, etc).

I am not sure where this default value is set... perhaps it is implicit that the default value is zero. Tried searching the code but didn't see anything obvious. https://github.com/LibreOffice/core/blob/e87071ac57a7711078715d9165c264ec3db180ab/starmath/source/node.cxx

Steps to Reproduce:
Install LibreOffice, try the formula '%rho'

Actual Results:  
Greek letter rho will be shown in non-italics.

Expected Results:
Should be in italics.


Reproducible: Always

User Profile Reset: Tried on various systems.

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Julien Nabet 2017-01-23 20:17:22 UTC
Considering https://bugs.documentfoundation.org/show_bug.cgi?id=52225#c24, why creating a new bugtracker?
Comment 2 Julien Nabet 2017-01-23 20:20:02 UTC
Oups, the other one is considered as fixed.
Forget my previous comment.
Comment 3 Julien Nabet 2017-01-23 20:46:55 UTC
I submitted a patch for master sources  waiting for review from devs here:
https://gerrit.libreoffice.org/#/c/33480/
Comment 4 V Stuart Foote 2017-01-23 21:31:24 UTC
Takeshi had issues about setting GreekCharStyle = 2 by default, see https://bugs.documentfoundation.org/show_bug.cgi?id=52225#c14 and #c15 not sure anything has changed.

With a new default GreekCharStyle = 2, new formulas would be protected--but old formulas created with GreekCharStyle = 0 default and using the i% or {italic | nitalic} direct formatting would be out of sync.

The annoyance would be transient as folks move beyond direct formatting, while a script to aid migration is feasible.

IMHO, a +1 for this adjustment.

@Takeshi?
Comment 5 Julien Nabet 2017-01-24 21:40:52 UTC
Since I don't know how to fix tests about this part, I gave up the patch.
Comment 6 Julien Nabet 2017-01-24 23:03:55 UTC
I finally gave it a new try and this time the commit is flagged as Verified on gerrit.
Comment 7 Takeshi Abe 2017-01-25 12:26:46 UTC
It would be better to make configuration on the style of Greek characters saved
into document so that the style is portable.
It will require more work than simply changing the default value of GreekCharStyle.
Comment 8 Julien Nabet 2017-01-25 13:17:26 UTC
(In reply to Takeshi Abe from comment #7)
> It would be better to make configuration on the style of Greek characters
> saved
> into document so that the style is portable.
> It will require more work than simply changing the default value of
> GreekCharStyle.

I don't think I'll be able to do this. Could it be a new bugtracker (an enhancement) so we could push the commit of this one?
Comment 9 Commit Notification 2017-01-26 18:55:25 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=68155a68578a0f4066c1c566c2d378bbae05c216

tdf#105483: let's put lowercase Greek letter in italic

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Takeshi Abe 2017-01-26 18:59:42 UTC
(In reply to Julien Nabet from comment #8)
> I don't think I'll be able to do this. Could it be a new bugtracker (an
> enhancement) so we could push the commit of this one?
Fair enough, then I can take care of such an enhancement.
Comment 11 Julien Nabet 2017-01-27 06:22:02 UTC
The commit isn't accepted for 5.3 branch (see comment in https://gerrit.libreoffice.org/#/c/33598/) so let's put this one to FIXED.