Bug 105540 - Exporting drawings to .eps deforms the labeling
Summary: Exporting drawings to .eps deforms the labeling
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-01-26 09:06 UTC by tr
Modified: 2017-10-21 21:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file .odg (8.22 KB, application/vnd.oasis.opendocument.graphics)
2017-01-26 09:54 UTC, tr
Details
Resulting file (16.66 KB, image/png)
2017-01-26 10:02 UTC, tr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tr 2017-01-26 09:06:05 UTC
Description:
Exporting drawings to .eps deforms labeling of objects if the labels have multiple words per row. E.g. if I have a rectangle with the following label: first line: This, second line: is a, thirds line: test, then the second line is deformed.

Steps to Reproduce:
1. Create a e.g. a rectangle
2. add a multi row labeling with two words in one of the rows
3. export to .eps

Actual Results:  
The labeling in the row with multiple words is deformed

Expected Results:
The labeling in the row with multiple words should not be deformed


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Xisco Faulí 2017-01-26 09:41:13 UTC Comment hidden (obsolete)
Comment 2 tr 2017-01-26 09:54:26 UTC
Created attachment 130691 [details]
Example file .odg

Example file .odg which fails when exporting the selection of the rectangle to .eps
Comment 3 Xisco Faulí 2017-01-26 09:58:09 UTC
Could you please attach the resulting document as well?
In my case, using

Version: 5.4.0.0.alpha0+
Build ID: d3ff66999d924e832f8219c65ced0526f1a67f82
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

the .eps isn't deformed
Comment 4 tr 2017-01-26 10:02:48 UTC
Created attachment 130692 [details]
Resulting file
Comment 5 V Stuart Foote 2017-01-26 15:50:07 UTC
On Windows 10 Pro 64-bit en-US with
Version: 5.3.0.2 (x64)
Build ID: 5ad7b2889021c491af62f7930a4b1cb631392f16
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: en-US (en_US); Calc: group


Can not confirm, I get correctly formed EPS (no preview, TIFF preview, or EPSI preview).

We'll need better STR

Your clip shows the ODG image as inserted into TEST.pdf

Are you exporting from Draw to .EPS? What settings?  And then what?

Do you get a clean PDF export from the Draw (the image internally there is SVG)?
Comment 6 tr 2017-01-27 09:37:31 UTC
My colleague observes the same problem with Version 5.2.3.5, also on a iMac. Probably, this problem only occurs on Macs. If I export to PDF, everything is fine. The problem only occurs when exporting from DRAW to .eps.
I used the following settings: Color, LZW encoding, Level 2
Comment 7 Alex Thurgood 2017-01-27 10:33:38 UTC
Confirming with

Version: 5.2.5.1
Build ID: 0312e1a284a7d50ca85a365c316c7abbf20a4d22
Threads CPU : 2; Version de l'OS :Mac OS X 10.12.2; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

I get the exact same result as the OP when using the default EPS export options on the selected text box.
Comment 8 Alex Thurgood 2017-01-27 10:38:30 UTC
I can also reproduce this with LO4452
Comment 9 Alex Thurgood 2017-01-27 10:47:52 UTC
No repro in LO330, so this is a regression.
Comment 10 Alex Thurgood 2017-01-27 10:54:05 UTC
No repro with 

Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
Comment 11 Alex Thurgood 2017-01-27 10:57:47 UTC
No repro with

Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
Comment 12 Alex Thurgood 2017-01-27 11:00:58 UTC
The problems first occur in LO4352 release
Comment 13 Xisco Faulí 2017-07-13 10:12:26 UTC
Setting Assignee back to default. Please assign it back to yourself if you're
still working on this issue
Comment 14 eisa01 2017-10-21 21:06:03 UTC
This works for me now. Exported EPS show correctly in Preview

Version: 6.0.0.0.alpha1+
Build ID: 15dce20e8b97dbd0179f01910ca4d0027e80ff4e
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-10-20_06:46:46
Locale: en-US (en_US.UTF-8); Calc: group