Bug 105620 - Cairo pattern to be filled into path is placed incorrectly
Summary: Cairo pattern to be filled into path is placed incorrectly
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0 target:5.3.1 target:5.2.6
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-30 17:47 UTC by Tor Lillqvist
Modified: 2021-03-30 03:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Suggested patch. (1.29 KB, patch)
2017-01-30 17:49 UTC, Tor Lillqvist
Details
Bugdoc (83.90 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-01-31 08:57 UTC, Tor Lillqvist
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tor Lillqvist 2017-01-30 17:47:28 UTC
Description:
See bugdoc to be attached soonish.

Basically, in doOperation() in canvas/source/cairo/cairo_canvashelper.cxx, in the Fill case, we need to use an offset in the pattern's transformation matrix so that the pattern actually ends up inside the path.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_3) AppleWebKit/602.4.8 (KHTML, like Gecko) Version/10.0.3 Safari/602.4.8
Comment 1 Tor Lillqvist 2017-01-30 17:49:02 UTC
Created attachment 130770 [details]
Suggested patch.
Comment 2 Xisco Faulí 2017-01-30 21:49:43 UTC
Hi Tor,
Shouldn't the patch be uploaded to gerrit instead?
Comment 3 Xisco Faulí 2017-01-31 08:56:16 UTC
I've just found the gerrit patch: https://gerrit.libreoffice.org/#/c/33723/

Moving to NEW
Comment 4 Tor Lillqvist 2017-01-31 08:57:25 UTC
Created attachment 130787 [details]
Bugdoc

In slideshow mode, the image is missing, the inside of the rounded rectangle is just black. The patch fixes this.
Comment 5 Commit Notification 2017-02-01 11:44:43 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b220bc6d82841b5b53b856d94a1eb99bb3a9f2d7

tdf#105620: Fix placement of image embedded in graphic

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-02-01 12:17:47 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=385c207e3a0b2d946ff29a9003b36f81a8946c55

tdf#105620: Probably better to not ignore initial x0 and y0

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Tor Lillqvist 2017-02-01 13:50:01 UTC
Possibly duplicate of bug #75209.
Comment 8 Commit Notification 2017-02-09 09:54:05 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=60e55044891305756fc3fdbcbd8ddbd592c40df9&h=libreoffice-5-3

tdf#105620: Fix placement of image embedded in graphic

It will be available in 5.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2017-02-09 09:55:33 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=562ea5ef1bf2dd8b110109c6d531489780b51c30&h=libreoffice-5-2

tdf#105620: Fix placement of image embedded in graphic

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2017-04-13 09:08:19 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 11 Luke 2017-10-04 05:29:13 UTC
 Xisco Faulí,
No it is not full fixed. The Bugdoc is still broken under Windows, but now renders correctly under Linux.

As Tor said, this is probably a dupe of Bug 75209 as that is working now under Linux.
Comment 12 Luke 2018-03-27 06:10:54 UTC
Bugdoc also still broken in Linux with 
Tools->Options->View->Hardware acceleration:disabled
Comment 13 QA Administrators 2019-03-28 04:20:08 UTC Comment hidden (obsolete)
Comment 14 Luke 2019-03-30 15:52:42 UTC
Still reproducible in both Linux and Windows in 6.2

In Windows with and without HW accel and OpenGL in Version: 6.3.0.0.alpha0+ (x64)
Build ID: c61623028b79f918d0ed2bc2ca47db17e68a26cb
Comment 15 QA Administrators 2021-03-30 03:39:25 UTC
Dear Tor Lillqvist,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug