Bug 105641 - svg export of single objects should produce SVG without javascript
Summary: svg export of single objects should produce SVG without javascript
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: x86 (IA32) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0
Keywords: filter:svg
Depends on:
Blocks: SVG-Save
  Show dependency treegraph
 
Reported: 2017-01-31 13:54 UTC by Regina Henschel
Modified: 2018-12-16 20:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2017-01-31 13:54:45 UTC
Take a presentation and select some objects on the slide. Export them to SVG. Make sure, that "Selection" is checked.

The exported file contains a large script element, multiple times larger than the pure svg. This javascript is needed for playing animations. But it is useless in case of an image, that contains only isolated objects from a slide.

Such export is mostly used, to insert the SVG image into text documents or other presentations or in a Gallery theme.

Current workaround is to copy&paste the selected objects into a dummy Draw document and export them from there.

Expected behavior: If "Selection" is checked and the selection contains only objects from one slide, then do not add the Javascript but export it same way as from a Draw page.
Comment 1 Commit Notification 2017-03-27 20:58:11 UTC
Chr. Rossmanith committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f900888ba51803d924bb5129978aa891879ecc59

tdf#105641: no javascript in svg export for selection of objects

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Xisco Faulí 2017-07-14 13:19:02 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2017-11-05 21:30:33 UTC
A polite ping to Chr. Rossmanith: is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Thanks
Comment 4 Regina Henschel 2017-11-05 21:43:16 UTC
No, it is not fixed. There is no JavaScript, but the pages still exist and because they are hidden for to work with the JavaScript, no object is shown, if the file e.g. is opened in browser.

I have tested it in Version: 6.0.0.0.alpha1+
Build ID: d30522e46ca884e9bc74af21711d9537e8118859
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-29_23:13:14
Locale: de-DE (de_DE); Calc: group