Bug 105696 - Conditional Formatting not updating immediately after editing source value
Summary: Conditional Formatting not updating immediately after editing source value
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All Windows (All)
: medium minor
Assignee: Markus Mohrhard
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.1 target:5.4.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2017-02-02 11:32 UTC by Jerzy Moruś
Modified: 2017-07-24 12:43 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jerzy Moruś 2017-02-02 11:32:44 UTC
Calc 5.2.3.3, Windows 10 64b
When selecting the option "All Cells" properly functioning appeal to make formula.
Changing values in the formula's cells does not affect the conditional formatting.
You need to reignite edit formatting. The same edition of the call will change the formatting
See and test for example here https://wiki.documentfoundation.org/images/f/ff/FAQ.CALC_142_ColorScale.ods
In my old Calc version (5.0.2) on Windows 10 32b everything was O.K.
After installing a new version it is like above.
Comment 1 Xisco Faulí 2017-02-02 13:18:39 UTC Comment hidden (obsolete)
Comment 2 Jerzy Moruś 2017-02-02 17:08:26 UTC
In version 5.3.0.3, nothing has changed.
In addition, when selecting a "Icon set" can not see any fields to set parameters for this formatting.
I have to go back to the previous version.
Comment 3 Buovjaga 2017-02-07 13:00:10 UTC
Tested: edited E11 and changed the value to 15. It changed to blue immediately.

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+
Build ID: 83e059af2203ec0cd15dea08cfa538555ba14bd7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-06_23:34:43
Locale: fi-FI (fi_FI); Calc: group
Comment 4 Jerzy Moruś 2017-02-07 20:53:05 UTC
If we talk about CALC_142_ColorScale.ods, see for change cell M40 for example from 10 to 30. The problem is in this presentation.
Comment 5 Buovjaga 2017-02-09 13:19:35 UTC
(In reply to Jerzy Moruś from comment #4)
> If we talk about CALC_142_ColorScale.ods, see for change cell M40 for
> example from 10 to 30. The problem is in this presentation.

Ok, it is not updated immediately. I had to switch window focus and then it updated.

I confirm it worked in 5.0.2

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+
Build ID: 83e059af2203ec0cd15dea08cfa538555ba14bd7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-06_23:34:43
Locale: fi-FI (fi_FI); Calc: group
Comment 6 Jerzy Moruś 2017-02-09 19:42:48 UTC
This phenomenon applies to all kinds of formatting in the type of "All cels".
The update will occur even after a small resized of window.
Comment 7 Aron Budea 2017-02-10 23:35:55 UTC Comment hidden (bibisection)
Comment 8 Aron Budea 2017-02-10 23:38:03 UTC
This issue started with the commit referenced below. Adding Cc: to Markus Mohrhard, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=88a0c7d01b7dfd085a0569030f97cc7de0f0d106
author		Markus Mohrhard <markus.mohrhard@googlemail.com>	2016-03-26 12:11:53 (GMT)
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2016-03-26 15:59:20 (GMT)

"switch to a listener based cond format update, tdf#95437"
Comment 9 Markus Mohrhard 2017-02-13 17:43:08 UTC
Can you please check with a current master daily build. At least changing M40 works for me with an update to the conditional format.
Comment 10 Buovjaga 2017-02-17 12:58:11 UTC
(In reply to Markus Mohrhard from comment #9)
> Can you please check with a current master daily build. At least changing
> M40 works for me with an update to the conditional format.

No, still requires some changing of focus, zooming etc.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 4cdd4b47ba62a75aadfd5cab166acfdbc31b9b71
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 17th 2016
Comment 11 Markus Mohrhard 2017-03-16 21:10:22 UTC
So it is a bit more complicated. The row that is changed is actually updated and just not the whole color scale range. This obviously will affect all the range based conditional formats as they share the same listener code.
Comment 12 Commit Notification 2017-06-28 02:33:39 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=49922897d68835ae4e5c850b3c55107157fe7548

repaint whole range for range based cond formats, tdf#105696

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2017-07-13 16:19:22 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6ed7a3085216caf29f9066154fccc6ee2f1b953d&h=libreoffice-5-4

repaint whole range for range based cond formats, tdf#105696

It will be available in 5.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2017-07-21 09:36:26 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3aa9933caa929e454b68e6efc1f21d485c483932&h=libreoffice-5-4-0

repaint whole range for range based cond formats, tdf#105696

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.