Bug Hunting Session
Bug 105699 - Arial and Times New Roman italics not falling back correctly, when used with Arabic text
Summary: Arial and Times New Roman italics not falling back correctly, when used with ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-02-02 12:09 UTC by yousifjkadom
Modified: 2019-11-17 15:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yousifjkadom 2017-02-02 12:09:31 UTC
Please look to following attached files (2 docx & 4 screenshots) as following:

attachment 130832 [details] Arial.docx : show writing in Arabic "arial" italic. Please compare following screenshots:

attachment 130834 [details] Arial-libreoffice (screenshot for "Arial.docx" as appear in libreOffice) &

attachment 130835 [details] Arial-MSoffice (screenshot for "Arial.docx" as appear in MS office)

Look for difference: in MS office correct font displaysment while wrong display of arial font in LibreOffice.

--------------------

attachment 130833 [details] TimeNewRoman.docx : show writing in Arabic "time new Roman" italic. Compare following 2 screenshots:

attachment 130836 [details] TimeNewRoman-libreoffice (screenshot for "TimeNewRoman.docx" as appear in libreoffice) &

attachment 130837 [details] TimeNewRoman (screenshot for "TimeNewRoman.docx" as appear in MSoffice)

Look for difference: in MS office correct font displaysment while wrong display of time new Roman font in LibreOffice.

Please your kind fix ! I do not know if it is better to open new bug or post it here. If it is better to open new bug then please separate this post as new bug.

Best
Comment 1 Buovjaga 2017-02-07 13:15:12 UTC
Confirmed. I also tried a clean copy and paste to a new document and same result when turning on Italics.

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+
Build ID: 83e059af2203ec0cd15dea08cfa538555ba14bd7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-06_23:34:43
Locale: fi-FI (fi_FI); Calc: group

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 2 QA Administrators 2018-02-08 03:35:30 UTC Comment hidden (obsolete)
Comment 3 yousifjkadom 2018-02-23 09:34:42 UTC
Hi. Please any one, other than me, to test this bug on L.O version 6.0 on Windows OS because at this time I have no any PC with Windows ! I'm now a pure Linux user. Since your request to review this bug, I searched for testing it on Windows PC but a had no chance ......

This bug is ONLY appear on Windows. It is NEVER EVER effected Linux. For that I can not test it further ...... We need a user with Windows OS to test it.

I'm sorry for this but I did what in my capacity ......
Comment 4 Buovjaga 2018-02-23 17:40:15 UTC
Ok, I adjusted the summary to be accurate. I assume even Microsoft Word is substituting the font, when italics is used.

But now with LibreOffice 6.1, when I try from scratch, I just get boxes when turning on italics.

Testers can try by copying this:


اسمي يوسف جواد كاظم وانا احب برنامج ليبر اوفس لانه رائع
اسمي يوسف جواد كاظم وانا احب برنامج ليبر اوفس لانه رائع

Version: 6.1.0.0.alpha0+ (x64)
Build ID: e1082e45361a92a31adedcc3ed0a35c704bca543
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-02-15_23:24:06
Locale: fi-FI (fi_FI); Calc: group
Comment 5 QA Administrators 2019-02-24 03:40:39 UTC Comment hidden (obsolete)
Comment 6 yousifjkadom 2019-11-17 08:38:04 UTC
Hi. I can not follow this issue further, because I have no Windows OS on my PC ! I shifted completely to Linux.

Please to examine this issue by users who own Windows on their machines .....

This issue is ONLY LIMITED TO WINDOWS OS.
Comment 7 Buovjaga 2019-11-17 15:24:04 UTC
Yousif: you can tick the box "Ignore Bug Mail" and save changes, if you don't want to get notifications from this report. I can continue testing every year on Windows.

Still turns to boxes.

Version: 6.4.0.0.alpha1+ (x64)
Build ID: 7c6226bee72805db7f0e567ca9f06c786a7d0da2
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded