Bug Hunting Session
Bug 105708 - files with extension .odt in windows explorer open in background
Summary: files with extension .odt in windows explorer open in background
Status: RESOLVED DUPLICATE of bug 75471
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.5.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-02 17:28 UTC by joachim.krecher
Modified: 2017-02-05 02:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description joachim.krecher 2017-02-02 17:28:49 UTC
Description:
Double-cklicking a file in Windows Explorer produced by LibreOffice Writer and having the normal extension .odt creates an entry in the task line (below); clicking this entry gets the LibreOffice Writer surface into the foreground with the selected file shown.

This happens with the "preload" of LibreOffice Writer at the moment of starting the PC as well as without this what I have called preload.

What is expected is the "normal" behaviour of double-clicking a file in the explorer: the program connected with the type of that file (e.g., .pdf or .txt) is started, the file loaded and shown immediately on the screen (of course an additional entry is found in the task line). This procedure is executed successfull with pdf- and other types of files.

Changing the registry values of "ForegroundFlashCount" and of "ForegroundLockTimeout" in HKEY_CURRENT_USER\CONTROL PANEL\DESKTOP both to zero did not help.


Steps to Reproduce:
1.Opening windows explorer
2.Finding the file (which has the extension .odt)
3.Double-clicking the name of that file 

Actual Results:  
The task line has a new entry

Expected Results:
The program (swriter.exe) is started and the selected file "opened" IMMEDIATELY in the foreground


Reproducible: Always

User Profile Reset: No

Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Builds ID: LibreOffice 5.2.5.1


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Aron Budea 2017-02-05 02:51:12 UTC

*** This bug has been marked as a duplicate of bug 75471 ***