Bug Hunting Session
Bug 105710 - Implement GUI control of OpenType features
Summary: Implement GUI control of OpenType features
Status: RESOLVED DUPLICATE of bug 58941
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.2 rc
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-02-02 18:03 UTC by Juergen
Modified: 2017-04-05 11:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen 2017-02-02 18:03:16 UTC
Description:
With the actual LO-version (5.3.0.3) »OpenType layout is now supported on all platforms, and default OpenType features are enabled for all languages« (https://wiki.documentfoundation.org/ReleaseNotes/5.3#Text_Layout). But there is no possibility to controll the use of the features. For example ligatures are set no by default. But I want to decide, if I want to use them or not. The same is with text/old style figures and other features. And how can I work with typographic correct small caps and not with digital generated wrong small caps?

Actual Results:  
OpenType features are enabled by default, so cannot controll them.

Expected Results:
There has to be implemented a controll-dialog concerning the specific use of OpenType features.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Maxim Monastirsky 2017-02-02 22:43:09 UTC
(In reply to Juergen from comment #0)
> With the actual LO-version (5.3.0.3) »OpenType layout is now supported on
> all platforms, and default OpenType features are enabled for all languages«
> (https://wiki.documentfoundation.org/ReleaseNotes/5.3#Text_Layout). But
> there is no possibility to controll the use of the features.
There is. The release notes also state that "OpenType layout features can be controlled using the syntax previously only supported for Graphite fonts."

Suppose you use Calibri font and want to disable ligatures, you can type this in the font name box:

Calibri:-liga

And to enable small caps:

Calibri:smcp

And so on. And you can combine several settings with &.
Comment 2 Juergen 2017-02-02 23:29:01 UTC
(In reply to Maxim Monastirsky from comment #1)
> (In reply to Juergen from comment #0)
> > With the actual LO-version (5.3.0.3) »OpenType layout is now supported on
> > all platforms, and default OpenType features are enabled for all languages«
> > (https://wiki.documentfoundation.org/ReleaseNotes/5.3#Text_Layout). But
> > there is no possibility to controll the use of the features.
> There is. The release notes also state that "OpenType layout features can be
> controlled using the syntax previously only supported for Graphite fonts."
> 
> Suppose you use Calibri font and want to disable ligatures, you can type
> this in the font name box:
> 
> Calibri:-liga
> 
> And to enable small caps:
> 
> Calibri:smcp
> 
> And so on. And you can combine several settings with &.

Sorry Maxim, but this is absolutly unconfortable und for the ›normal‹ user unpractical, inacceptable. Nobody, except IT-experts, likes to work with cryptic syntax. That way, I fear, OpenType-features will not be widley used. I hope very much, that LO or Writer will soon get implemented an appropriate, ›user-friendly‹ toolbar, sidebar, controll-window-dialogue or something like this. Bothersome is also that OpenType-features like ligatures are enabled by default, regardless of whether I want them in the text or not. It cannot simple be disabled by the user, right?
Comment 3 V Stuart Foote 2017-02-03 17:23:25 UTC
We'll mark this as an enhancement then. But not clear there is a priority to provide GUI support for applying and tracking OpenType features [1] beyond the current application/display in the Character style dialog and Sidebar content panel.

Some effort could be made to map the OpenType features onto the Character dialog Font Effects tab to provide a GUI, but that would be for a limited subset of features.

But IMHO the most efficient is what exists now, applying the feature directly as direct formatting or by defining and applying it in a style. 

All without cluttering the UI with implementing GUI for infrequently used typographic widgets.


=ref-=
[1] https://www.microsoft.com/typography/otspec/featurelist.htm
Comment 4 Khaled Hosny 2017-02-03 17:27:13 UTC
The lack of UI is one of the reasons why big 58941 is still open, no need for a new bug.

*** This bug has been marked as a duplicate of bug 58941 ***
Comment 5 Khaled Hosny 2017-02-03 17:30:10 UTC
See also bug 105454.
Comment 6 Volga 2017-04-03 06:16:38 UTC
This can be done via creating an extension to intergrate such interfaces.
Comment 7 Juergen 2017-04-03 09:04:57 UTC
There is an old extension called ›Typography toolbar‹ (https://extensions.libreoffice.org/extensions/typography-toolbar). But the latest release is from 2013 and it does’t work with the actuall LO-version 5.3.1.2. Perhaps someone can concern himself with this.
Comment 8 Volga 2017-04-05 11:24:19 UTC
That is what I proposed in comment 6, I think a new extension compatible with latest LO 5.3.1.2 would be more suitable.