Bug 105758 - Writer 5.3.0.3 Truncates Alphabetical Index Entries
Summary: Writer 5.3.0.3 Truncates Alphabetical Index Entries
Status: RESOLVED DUPLICATE of bug 104315
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-04 23:08 UTC by LibreTraining
Modified: 2017-02-09 20:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Index test document - one page with indexes (17.46 KB, application/vnd.oasis.opendocument.text)
2017-02-04 23:10 UTC, LibreTraining
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LibreTraining 2017-02-04 23:08:08 UTC
Description:
Writer 5.3.0.3 truncates Alphabetical Index entries by deleting the last character in the term.

I have been working on an Index in a long document using Writer 5.2.5.1.
I modified the default index format to conform to well known style manuals.

The entries should look like this:
Access2Base, 1
LibreOffice, 2

Instead they look like this:
Access2Bas, 1
LibreOffic, 2

It works correctly in Writer 5.2.5.1.
It does NOT work correctly in Writer 5.3.0.3.

Attached is a demo document.
The document is simply one paragraph with some index terms marked, and two indexes inserted below - upper index has the default settings, the lower index has been modified by deleting the [T} (tab) and entering instead ", " (comma space).

Open the demo document in Writer 5.2.5.1 and refresh both indexes.
- Default index format works
- Modified format works

Open the demo document in Writer 5.3.0.1 and refresh both indexes.
- Default index format works
- Modified format does NOT work - truncates the last character of each term
 



Steps to Reproduce:
1. Insert an Alphabetical Index
2. Modify Alphabetical Index default format.
3. Delete the [T] (tab) and enter ", " (comma space)
4. Save
5. Update the index



Actual Results:  
The expected results are an index where the terms are not missing the last character.

Expected Results:
Truncated index terms.


Reproducible: Always

User Profile Reset: No. Does not appear relevant.

Additional Info:
This was all working fine in recent Writer v5.2.x.x versions.
The problem appeared with the update to Writer v5.3.0.3.

The index format I am using is the format recommended in both The Chicago Manual of Style, and The Oxford Guide to Style.

So I would say it is fairly important that this works properly in Writer.


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 LibreTraining 2017-02-04 23:10:14 UTC
Created attachment 130910 [details]
Index test document - one page with indexes
Comment 2 Aron Budea 2017-02-04 23:37:42 UTC

*** This bug has been marked as a duplicate of bug 104315 ***
Comment 3 LibreTraining 2017-02-09 20:49:21 UTC
Just tested with other characters replacing the tab.
- Comma alone - same problem, truncates last letter.
- Underline character alone - same problem, truncates last letter.
- Letter X alone - same problem, truncates last letter.

So this bug affects virtually any change which deletes the tab entry.


Furthermore it makes no sense for the default index format to include this tab.
It would make more sense for the default index format to be what is actually used in professional documents.
Pick up virtually any textbook or technical book on your bookshelf and take a look at the index.
It will most like likely have an index formatted as recommended by The Chicago Manual of Style and/or The Oxford Guide to Style.

Neither of these guides recommends an Index format which looks like a Table of Contents.
It would make more sense for the default Index format in LibreOffice to follow the recommendations of these industry-standard guides - like virtually every book on your bookshelf.
Why should LibreOffice users have to fix this every time they make a new document?
That is just dumb.