Bug Hunting Session
Bug 105784 - rendering problem with font "Druckschrift95" (official austrain schoolfont)
Summary: rendering problem with font "Druckschrift95" (official austrain schoolfont)
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.2 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-02-06 06:17 UTC by cw
Modified: 2017-02-08 21:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot from writer where one can see the wrong line spacing (4.94 KB, image/png)
2017-02-06 06:17 UTC, cw
Details
Screenshot of the font on the font viewer (312.14 KB, image/png)
2017-02-06 21:08 UTC, Khaled Hosny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cw 2017-02-06 06:17:55 UTC
Created attachment 130930 [details]
screenshot from writer where one can see the wrong line spacing

Coming from v5.2.5 all writer documents containing this font are rendered wrong. The line spaceing seems to be to narrow (see attached screenshot from writer).

How to reproduce:
1. Install the font "Druckschrift95" (http://lehrerweb.wien/fileadmin/user_files/redakteure/lw_spezial/service/download/DRUCKSCH_07.ttf)
2. Start Writer, Calc or Draw
3. Switch to font "Druckschrift95"
4. Start writing


Reproduced on two different computers, both Windows 10 and Libreoffice v5.3.0.3. Problem vanishes when I uninstall v5.3.0.3 and install v5.2.5 again.
Comment 1 Regina Henschel 2017-02-06 14:17:00 UTC
It is OK in Version: 5.2.5.0.0+
Build ID: feacae8571d003c60960d852e835a17ef722265c
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-2, Time: 2016-12-01_11:03:34
Locale: de-DE (de_DE); Calc: group

OK in Version: 5.3.0.0.alpha1+
Build ID: 92c1128fb80b4e38df219ce60f018cfb1522b20a
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-11-19_23:47:55
Locale: de-DE (de_DE); Calc: group

It is broken as shown in the screenshot in
Version: 5.3.0.0.beta1
Build-ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU-Threads: 4; BS-Version: Windows 6.1; UI-Render: Standard; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 2 Khaled Hosny 2017-02-06 21:08:55 UTC
Created attachment 130963 [details]
Screenshot of the font on the font viewer

That is not a HarfBuzz issue, but related to the new line spacing handling introduced in 5.3.

This is simply a case of broken font, the descender in both “OS/2” and “hhea” font tables is positive but it should be negative. I don’t like having to workaround such broken fonts as it might break legitimate fonts. LibreOffice is not, and will not be the only application having issues with such font, I’m attaching a screenshot showing how the font is rendered in the font viewer on my system.
Comment 3 V Stuart Foote 2017-02-07 00:05:14 UTC
Agree, with Khaled--not a HarfBuzz layout issue, and that fonts with bad metrics that previously sliped by with OS/2 metrics must now be treated as NOT A BUG/NOT OUR BUG.

User beware--fix your broken fonts, or better don't use them.  We've formally done that with legacy PS Type1 and numerous bitmap fonts.