Bug 105808 - make the scroll bar useful for really large documents, currently it is too sensitive for them
Summary: make the scroll bar useful for really large documents, currently it is too se...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.2 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Scrollbars
  Show dependency treegraph
 
Reported: 2017-02-06 20:11 UTC by Adalbert Hanßen
Modified: 2017-02-12 20:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adalbert Hanßen 2017-02-06 20:11:40 UTC
If you have long documents, e.g. one with more than 100 pages or even with more than 500 pages the "elevator" gets smaller and smaller as it reflects the proportion of the document shown on one full screen window with respect to the whole document. Also the elevator shows the position of the current display window with respect to the whole document.

This is well understood and it was appropriate for small documents up to say 100 pages.

For larger documents it gets worse, especially if the documents get much larger than 100 pages. I have some with 300++ pages and even some with 500+pages. But doing small adjustments by using the scrollbar gets annoying with those documents.

For larger documents the rule "the length of the elevator reflects the portion of a full height window with respect to the whole document" should be given up: The elevator should not get smaller than 7 mm or even 10mm, so you have 3.5mm or even 5mm up and down from its middle.

If you click on the elevator, the mouse cursor always should always initially attach itself on the middle of the elevator to add some dynamic feature as described below:

If you move the mouse with the (left) mouse switch pressed, the speed of display movement should be limited to some maximum speed of say at most 5 pages per second as long as the mouse-attached indicator is displaced from the middle of the elevator and stays in the elevator (this maximum speed from inside the elevator should be a configuration item). The speed should depend on the amount of the actual displacement from the middle height of the elevator.

After this improvement has been added, you can easily shift the displayed portion of the document by small amounts. If you leave it a bit displaced from the middle but on the elevator and with the key pressed, the display movement eventually will come to a halt when due to the displayed portion movement, the elevator is centered again under the current mouse position. Of course, scrolling should always be interrupted as soon as the mouse key is released.

Now we need some other means to control large scrolls in the document: If the mouse-pointer is moved out of the elevator but stays still in the elevator shaft, the elevator should switch to higher gears. It still should have a maximum scrolling speed of say 500 pages per second (also something which should be configured) as soon as the mouse pointer is in the elevator more than 4 cm away from the middle of the center of the elevator (the elevator then gets attracted by a very strong spring). The scrolling speed should depend on the displacement off the elevator. Of course, if the mouse key gets no longer depressed, scrolling should stop immediately. If you would move the mouse pointer (with mouse key pressed) on the scroll bar to some estimated portion of the document ad stop it there holding the key pressed, as the elevator approaches the mouse position, the elevator speed would continuously decrease coming to a soft rest when the mouse pointer is centered on the middle of the elevator again as a consequence of the elevator movement. As the elevator is softly approaching its destination, the user can still correct the final position by moving the mouse a bit up or down.

This improvement would make the scrolbar useful for large documents. Of course, this proposal is not limited to LO Writer, it might be applied in the other LO products too.
Comment 1 V Stuart Foote 2017-02-12 19:52:03 UTC
Navigating in long documents is already efficiently handled--just with the Navigator UI. Set Bookmarks and/or section Headings.

There is no reason to adjust scroll bar behavior to something more complex, beyond possibly providing a by "page" movement button Up/Down (uno:PreviousPage and .uno:NextPage) command as provided in Navigator and Toolbars.

IMHO a WONTFIX.
Comment 2 Heiko Tietze 2017-02-12 20:46:02 UTC
How the scrollbar works is defined by the operating system/desktop environment and messing around with those defaults always ends in a much worse scenario. And actually the _thumb_ behaves exactly as you describe on my system (LXQt, KWin, Breeze): it becomes smaller with increasing number of pages, but only up to around 200. After that it remains large enough to easily deal with it. Admitted that scrolling to a particular position is not fun.

The issue boils down how to deal with large documents. And as Stuart pointed out we have the Navigator for this purpose. Plus the newly introduced dialog Edit > Go to page (ctrl+G). You have also a lot of other supportive functions to find a certain position, for instance bookmarks or a table of contents with links.