Bug Hunting Session
Bug 105880 - Letters are not aligned in rotated text, when OpenGL is enabled
Summary: Letters are not aligned in rotated text, when OpenGL is enabled
Status: RESOLVED DUPLICATE of bug 100986
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering VCL-OpenGL HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2017-02-09 13:37 UTC by lukas alberts
Modified: 2017-02-13 15:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots from 5.2 and 5.3 (10.93 KB, image/png)
2017-02-13 11:21 UTC, Buovjaga
Details
opengl-unchecked (193.92 KB, image/jpeg)
2017-02-13 13:44 UTC, lukas alberts
Details
wrong view (1.08 KB, text/plain)
2017-02-13 13:46 UTC, lukas alberts
Details
wrong-view.. mistaken before..was anyway opencl.log (185.96 KB, image/jpeg)
2017-02-13 13:48 UTC, lukas alberts
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lukas alberts 2017-02-09 13:37:33 UTC
upgrading to 5.3 from 5.2.5 the Text alignement behaviour changes in the cells of calc.
previous version, the letter follow a line which is oblique,

new version, the letters keep horizontal but are shifted along the oblique line, which makes it unreadable !!

the feature may be nice, but please add it as an option and have the previous as defaut setting..

Thanks
Lukas
Esslingen
Comment 1 Buovjaga 2017-02-11 20:46:08 UTC
Please attach a screenshot, I don't understand the problem.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the screenshot.
Comment 2 Buovjaga 2017-02-13 11:21:45 UTC
Created attachment 131173 [details]
Screenshots from 5.2 and 5.3

The reporter sent this to me via direct email for some reason.
Comment 3 Buovjaga 2017-02-13 11:25:18 UTC
I tried to reproduce it: I wrote something to a cell and then in Sidebar - Properties - Text orientation: 65. It is shown like in your 5.2.

Please copy and paste the contents of your Help - About. It will show us, if you have OpenGL enabled.

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+
Build ID: 1d810b69a584fc33f4178c7012f68f551ba2e03b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-12_23:34:02
Locale: fi-FI (fi_FI); Calc: CL
Comment 4 Buovjaga 2017-02-13 12:59:48 UTC
Reporter again emailed me directly. It is now clear he is using OpenGL.

Lukas: what happens, if you disable it: Tools - Options - LibO - View - Use OpenGL for all rendering?

Please also copy and paste TO A COMMENT the contents of your C:\Users\User\AppData\Roaming\LibreOffice\4\cache\opengl_device.log
Comment 5 Thomas Lendo 2017-02-13 13:07:32 UTC
I can't reproduce the issue. Created a file in 5.1.4.2, inserted text with orientation of 65° and saved it. Opened in 5.3.0.3 and it looks identical/correct. OpenGL and OpenCL activated (Windows 10).

Version: 5.3.0.3
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
Locale: de-DE (de_DE); Calc: CL
Comment 6 lukas alberts 2017-02-13 13:44:00 UTC
Created attachment 131176 [details]
opengl-unchecked

unchecking openGL is good
Comment 7 lukas alberts 2017-02-13 13:46:13 UTC Comment hidden (obsolete)
Comment 8 lukas alberts 2017-02-13 13:48:26 UTC
Created attachment 131178 [details]
wrong-view.. mistaken before..was anyway opencl.log
Comment 9 lukas alberts 2017-02-13 13:49:15 UTC
wrong view

DriverVersion: 21.21.13.7290
DriverDate: 9-16-2016
DeviceID: PCI\VEN_10DE&DEV_0FFA&SUBSYS_094B10DE&REV_A1
AdapterVendorID: 0x10de
AdapterDeviceID: 0x0ffa
AdapterSubsysID: 0x094b10de
DeviceKey: System\CurrentControlSet\Control\Video\{13B34804-8DCA-4789-B893-C8D5F6324B05}\0001
DeviceString: NVIDIA Quadro K600
Comment 10 V Stuart Foote 2017-02-13 15:34:10 UTC

*** This bug has been marked as a duplicate of bug 100986 ***