Bug 105919 - SIDEBAR scrolling with Scroll Bar
Summary: SIDEBAR scrolling with Scroll Bar
Status: RESOLVED DUPLICATE of bug 84704
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: Scrollbars
  Show dependency treegraph
 
Reported: 2017-02-10 15:17 UTC by Gabriele Ponzo
Modified: 2017-02-12 19:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
See where to click to reproduce the Bug (45.39 KB, image/png)
2017-02-10 15:22 UTC, Gabriele Ponzo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele Ponzo 2017-02-10 15:17:55 UTC
Description:
If you click in the "empty" area of the scroll bar (when visible) it scrolls just 1 pixel per click!

Steps to Reproduce:
1. Open whatever module (Writer, Calc, Impress or Draw)
2. Import an image (to have the SideBar full of sections and thus scrollable)
3. Expand all the sections (by clicking on + on every one)
4. Click on the empty area of the scroll bar

Actual Results:  
It scrolls one pixel per click.

Expected Results:
It should scroll of one graphical page, meaning the exact amount of pixels shown, if available, otherwise to the end of the bar.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Gabriele Ponzo 2017-02-10 15:22:31 UTC
Created attachment 131079 [details]
See where to click to reproduce the Bug
Comment 2 V Stuart Foote 2017-02-10 19:10:35 UTC
Hmm, confirming 1px scroll on click.

On Windows 8.1 Ent 64-bit en-US with
Version: 5.3.0.3 (x64)
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 8; OS Version: Windows 6.29; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

Also, on Windows build the scrollbar has end buttons, clicking those moves the pane 1px-so assume that is intentional.

Click + hold + drag on the "slider" scrolls smoothly. And mouse "wheel" scroll is reasonably smooth at about ~5px increments. Not sure this needs any effort, but lets ask the dev.

@Thomaž, should the scrollbar button widgets or a click move in larger increments? Even adjust increment to match the length of the pane exposed (i.e. length of the gray slider)?
Comment 3 V Stuart Foote 2017-02-12 19:49:17 UTC

*** This bug has been marked as a duplicate of bug 84704 ***