Bug Hunting Session
Bug 105925 - Alt Gr / Alt + Ctrl does not work appropriately with "N" letter - opens "Narzędzia" ("Tools") menu instead of writing "ń"
Summary: Alt Gr / Alt + Ctrl does not work appropriately with "N" letter - opens "Narz...
Status: RESOLVED DUPLICATE of bug 97908
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-AltGR
  Show dependency treegraph
 
Reported: 2017-02-10 18:26 UTC by Krzysztof Borowiak
Modified: 2018-02-05 01:35 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Krzysztof Borowiak 2017-02-10 18:26:11 UTC
Description:
When trying to write Polish diacritic characters, user can use three options:
- Write "~" ("tylda") and the letter of choice that is to be converted to diacritic, eg. ~n = ń, ~o = ó, etc.
- Press Ctrl+Alt+letter, eg. Ctrl+Alt+n = ń, Ctrl+Alt+o = ó
- Press AltGr (right alt) + letter, eg. AltGr+n = ń, AltGr+o = ó

I checked out in different applications than LibreOffice, and the problem does not appear. It appears only in LibreOffice. I am sure it is at least since 5.2 version, maybe longer.

I checked out with language of system set to Polish, and keyboard mapping set to QWERTY Polish (programmist), which is default here.

I checked out with LibreOffice interface set to Polish, as well as English, getting different results.

When writing any of Polish diacritics: "ęóąśłżźć" everything works fine until it's about letter "ń". Letter "ń" doesn't appear in any of two latter options. So, writing ~n does make ń, but pressing Alt+Ctrl+n as well as AltGr+n does not create letter ń.

With Polish interface language set, it does open "Tools" menu, called in Polish interface "Narzędzia". It shall be only invoked by Left Alt (pressed and released to highlight top menu) followed by "n" letter. It seems like Right Alt = AltGr is not properly interpreted in current LibreOffice versions and maps as Left Alt when pressed together with "n" letter here.

But what's more funny is behavior of English interface version. When it is set, AltGr with "ń" does... erm... nothing. It's like nothing was written, but seems the top menu is highlighted as well, but without opening any menu. So it still seams that AltGr+"n" is making the AltGr being interpreted as Left Alt instead of Right Alt.

Tested on multiple LibreOffice applications for few last releases. Didn't test on 5.4. Don't remember if existed on 5.1. Certainly didn't exist on first releases of LibreOffice 5, and any of LibreOffice 4.

Steps to Reproduce:
1. Set up your computer input type to: Polish -> Polish (programmer) - with QUERTY layout
2. Open eg. Writer or Calc with user interface set to Polish or English
3. Try to write a letter ń using either: AltGr + n OR Alt + Control + n

Actual Results:  
Polish interface: "Narzędzia" (en. "Tools") menu is opened
English interface: Nothing happened, eventually Menu is highlightet

Expected Results:
ń letter shall be put down in the document


Reproducible: Always

User Profile Reset: Yes.

Additional Info:
I did also completely reinstall app, upgrade it for multiple months waiting for problem to be solved somehow, uninstall, clear all leftovers and clean install, try on different device with different version of OS. The problem still occurs on every device.

The problem is major, as the software is useless in both corporate and home environments with the diacritic character not working properly with AltGr type shortcut. Using the workaround with "~" ("tylda") is not the most comfortable solution, what makes it very uncomfortable to work.


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36
Comment 2 V Stuart Foote 2017-02-10 21:33:42 UTC
Seems for your locale, the <Alt>+n menu accelerator is asserting-- before the <AltGr>+n, or <Ctrl>+<Alt>+n IME action of placing the character with diacritic.

But, if you type in the Unicode value, 0144 leaving cursor there--an <Alt>+x toggles to the ń for you? Right? 

So, not an issue with rendering the glyph to document.

Rather an issue of mnemonic accelerators for menus conflicting with shortcuts like the IME provided.

@Caolán, Jurgen, Justin -- more in the same class as bug 100622, and bug 100908 --for work done on bug 95761, and still seems Simon Long's work on the <Alt> toggle action to expose mnemonic accelerators is involved (bug 92630)
Comment 3 Krzysztof Borowiak 2017-03-29 18:42:59 UTC
Hi, anything new happening in here? Please solve it, it makes LibreOffice mostly unusable in quick-writing production environment, forcing to move to Google Docs or MS Office (Online / on-premise)!
Comment 4 Krzysztof Borowiak 2017-03-29 18:44:06 UTC
I don't get this comment thing. Is it for the bug or for the comment type? :x

Sorry for spamming, I just wanted this thing to go ahead.
Comment 5 Caolán McNamara 2017-04-19 08:33:51 UTC
bug 92630 is almost certainly unrelated IMO
Comment 6 Aron Budea 2018-02-05 01:35:41 UTC
Should be fixed in 6.0.0.

*** This bug has been marked as a duplicate of bug 97908 ***