Bug Hunting Session
Bug 105934 - Some Diacritic positioning with Graphite font not working with LO 5.3
Summary: Some Diacritic positioning with Graphite font not working with LO 5.3
Status: RESOLVED DUPLICATE of bug 105913
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2017-02-11 10:42 UTC by Floater
Modified: 2017-06-02 01:39 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Doc with sample text containing diacritics (8.85 KB, application/vnd.oasis.opendocument.text)
2017-02-11 10:42 UTC, Floater
Details
Graphite font file (380.45 KB, application/x-font-ttf)
2017-02-11 10:47 UTC, Floater
Details
Correct rendering (111.34 KB, image/png)
2017-02-13 08:33 UTC, Floater
Details
Incorrect rendering (115.22 KB, image/png)
2017-02-13 08:33 UTC, Floater
Details
Illustrative doc coressponding to screenshots (8.89 KB, application/vnd.oasis.opendocument.text)
2017-02-13 08:35 UTC, Floater
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Floater 2017-02-11 10:42:19 UTC
Created attachment 131089 [details]
Doc with sample text containing diacritics

OS:Win XP

Diacritics are not positioned *at all* with LO 5.3 with the attached graphite font; works ok when "TextLayoutEngine" is set to "old" in Tools->Options->Advanced" : "Open expert config"

Set "TextLayoutEngine" to "old", close LO and open doc. Diacritic placement is Placement is ok.

Set "TextLayoutEngine" to "old", close Lo and open doc. Diacritic placement does not happen.

Obviously harbuzz is avoiding the 'base char" "diacritic" pair being positioned. Perhaps this should not be happening considering ---

"In a Graphite font, all smart rendering information resides within the font file. In order to display the Graphite smart rendering, an application needs only Graphite support, but no built-in knowledge about the writing system’s rendering. This makes Graphite especially suited for minority writing systems that cannot rely on applications to provide built-in rendering information. In this regard, Graphite is similar to AAT and different from OpenType which requires applications to provide built-in rendering information."

Regards
Venkatesh
Comment 1 Floater 2017-02-11 10:47:49 UTC
Created attachment 131090 [details]
Graphite font file
Comment 2 Buovjaga 2017-02-12 16:31:35 UTC
Can you give a screenshot of the bad display?
Comment 3 Floater 2017-02-13 08:33:11 UTC
Created attachment 131168 [details]
Correct rendering
Comment 4 Floater 2017-02-13 08:33:57 UTC
Created attachment 131169 [details]
Incorrect rendering
Comment 5 Floater 2017-02-13 08:35:27 UTC
Created attachment 131170 [details]
Illustrative doc coressponding to screenshots
Comment 6 Buovjaga 2017-02-13 11:49:33 UTC
Confirmed.

I earlier tested on Linux and remember it looked the same, so OS = All.

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+
Build ID: 1d810b69a584fc33f4178c7012f68f551ba2e03b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-12_23:34:02
Locale: fi-FI (fi_FI); Calc: CL
Comment 7 Khaled Hosny 2017-02-28 15:07:44 UTC

*** This bug has been marked as a duplicate of bug 105913 ***
Comment 8 Floater 2017-05-27 09:55:47 UTC
The issue is not a duplicate of bug 105913.

The issue is entirely different.

It is of graphite-font being completely self contained and not vetoed by Harfbuzz. 

Some diacritic-Base positionings in Graphite font are blocked by Hardfbuzz; they were not up to LO ver 5.2.

Pl re-visit my 1st post.

The bug remains in  LO ver 5.3.3.2
Comment 9 Floater 2017-05-28 08:55:30 UTC Comment hidden (obsolete)
Comment 10 V Stuart Foote 2017-05-28 18:20:52 UTC
So guess this is more than just lack of D2Write support for Windows XP with the new rendering engine. 

Seeing the same on a Windows 10 Pro 64-bit en-US with the Goda (Graphite) installed to system with:
Version: 5.4.0.0.alpha1+
Build ID: 774f033f86b3728123842321f21b10b400cf6b9a
CPU threads: 8; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-05-16_02:20:51
Locale: en-US (en_US); Calc: CL

Would note there are a lot of the diacritics defined in this font using Unicode 9 reserved codepoints for Kannada, e.g. U+0cbb, U+0cd1, U+0cd2 --not sure though if that would have any bearing on the Graphite combining characters failing.
Comment 11 Khaled Hosny 2017-06-02 01:39:43 UTC
(In reply to Floater from comment #8)
> The issue is not a duplicate of bug 105913.
> 
> The issue is entirely different.
> 
> It is of graphite-font being completely self contained and not vetoed by
> Harfbuzz. 
> 
> Some diacritic-Base positionings in Graphite font are blocked by Hardfbuzz;
> they were not up to LO ver 5.2.
> 
> Pl re-visit my 1st post.
> 
> The bug remains in  LO ver 5.3.3.2

I don’t what this all means, but unless you have an actual proof (like bisecting the changes) this is not a duplicate of bug 105913 please refrain from doing this again.

*** This bug has been marked as a duplicate of bug 105913 ***