Bug 105935 - Problem with change order record in table.
Summary: Problem with change order record in table.
Status: RESOLVED DUPLICATE of bug 71224
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-11 11:25 UTC by Pyroxar
Modified: 2017-02-12 16:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
images (569.30 KB, application/zip)
2017-02-11 11:25 UTC, Pyroxar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pyroxar 2017-02-11 11:25:26 UTC
Created attachment 131091 [details]
images

When i create table (e.g. "users"), i have record "name" and "last name" but i forgot add record "second name", I must create it ("second name" record) manually, ok.

It work fine.

New record has been add to end of table, I want have "name", "second name" and "last name" of users. I must change order records in the table.

I cut "last name", then "second name" is second record, i paste "last name" to end of table. It look great. I saved. I close the table and open again.

I see that "second name" is the end of table. It should be second record but It do not be.

I redesign table again and i save as "table1". Then and only then table was save correctly.

I add images in attachment.
Comment 1 Robert Großkopf 2017-02-12 09:53:29 UTC
You couldn't change the order of a table in the GUI when the table has been saved. It never worked.

The following code works with Tools - SQL:
ALTER TABLE "users" ADD "second name" VARCHAR(25) BEFORE "last name";

Use the following workaround:
Create a query when you have finished editing the table. 
Sort the fields in the query and work with the query.

Other possibility:
Copy the table, insert the table as new table, sort the fields in the wizard.

This Bug has been also described in bug 71224. So I will set this as DUPLICATE of 71224.

*** This bug has been marked as a duplicate of bug 71224 ***
Comment 2 Pyroxar 2017-02-12 12:14:32 UTC
It is not bug, It is feature. It do not work good. Your solutions are not intuitive. I think that it should be make better.

I reopen bug because It is important. I think that it was make wrong. It must be repaired.
Comment 3 Robert Großkopf 2017-02-12 15:39:55 UTC
(In reply to Pyroxar from comment #2)
> It is not bug, It is feature. It do not work good. Your solutions are not
> intuitive. I think that it should be make better.
> 
> I reopen bug because It is important. I think that it was make wrong. It
> must be repaired.

You have reported a bug. It doesn't work good. So it is a feature-request. The same feature-request as bug 71224. And I have set this as a duplicate of that feature-request.

I won't change anything more here. Should other people see this and set it again as duplicate.
Comment 4 Buovjaga 2017-02-12 16:34:16 UTC
Pyroxar: don't change the status of this report anymore.

*** This bug has been marked as a duplicate of bug 71224 ***